Bug 9339 - Build and quota fixes from master
Build and quota fixes from master
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
4.0.0rc3
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9232 9337 (view as bug list)
Depends on:
Blocks: 7472 8622 9232 9299 9337
  Show dependency treegraph
 
Reported: 2012-10-30 07:23 UTC by Andrew Bartlett
Modified: 2012-12-03 19:39 UTC (History)
2 users (show)

See Also:


Attachments
build and quota fixes from master (76.16 KB, patch)
2012-10-30 07:23 UTC, Andrew Bartlett
bjacke: review+
Details
Updated patch (91.47 KB, patch)
2012-11-02 09:21 UTC, Karolin Seeger
metze: review+
Details
Additional build fixes from master (19.56 KB, patch)
2012-12-03 11:04 UTC, Karolin Seeger
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2012-10-30 07:23:43 UTC
Created attachment 8121 [details]
build and quota fixes from master

Attached is a patch with most of the build and quota fixes from master since 4-0-test branched off.

I'm submitting this as one bug, as there are just too many small fixes to deal with one-by-one, but if there are objections, I'm happy for the objector to re-file as individual bugs. 

It builds correctly for me on FreeBSD 9.0 and Fedora 17
Comment 1 Björn Jacke 2012-10-30 12:24:18 UTC
Comment on attachment 8121 [details]
build and quota fixes from master

looks good to me
Comment 2 Michael Adam 2012-11-01 12:54:26 UTC
Andrew and Björn seem to support the patchset, so we can assign to Karolin.
Comment 3 Karolin Seeger 2012-11-02 07:42:42 UTC
Pushed to autobuild-v4-0-test.
Comment 4 Stefan Metzmacher 2012-11-02 08:01:55 UTC
It seems that there's one commit missing.

commit 2e51c386beff808e74c8c1f360a6f4db30fe74b5
Author: Andrew Bartlett <abartlet@samba.org>
Date:   Mon Sep 24 06:45:05 2012 +1000

    lib/replace: Look for special flags needed for c99

    This is normally handled by the waf core, but for HP-UX we currently fail.

    The autoconf code hard-codes a case for HP-UX, but I want to try testing
    it using a generic system first.

    Andrew Bartlett
Comment 5 Andrew Bartlett 2012-11-02 08:15:38 UTC
Well spotted.  It was actually deliberate, as when I built on FreeBSD, the gcc there 'accepted' the c99 flags, but then gave errors on stderr for every compile line.

Like the test for -Werror=format -Wformat=2 we probably need to actually test a C99 fragment, and only add a flag if we actually need it, not just because it doesn't cause the compiler to error.
Comment 6 Karolin Seeger 2012-11-02 09:21:27 UTC
Created attachment 8133 [details]
Updated patch

This one should include all fixes.
Comment 7 Stefan Metzmacher 2012-11-02 09:22:22 UTC
Comment on attachment 8133 [details]
Updated patch

Looks good
Comment 8 Karolin Seeger 2012-11-02 09:25:29 UTC
Pushed updated patchset to autobuild-v4-0-test.
Comment 9 Michael Adam 2012-11-02 20:34:10 UTC
*** Bug 9337 has been marked as a duplicate of this bug. ***
Comment 10 Michael Adam 2012-11-05 09:37:58 UTC
*** Bug 9232 has been marked as a duplicate of this bug. ***
Comment 11 Karolin Seeger 2012-11-05 09:58:32 UTC
Has been pushed to v4-0-test.
Closing out bug report.

Thanks!
Comment 12 Karolin Seeger 2012-12-03 11:03:26 UTC
More build fixes need to be backported from master.
Comment 13 Karolin Seeger 2012-12-03 11:04:19 UTC
Created attachment 8262 [details]
Additional build fixes from master
Comment 14 Stefan Metzmacher 2012-12-03 11:05:08 UTC
Comment on attachment 8262 [details]
Additional build fixes from master

Looks good
Comment 15 Karolin Seeger 2012-12-03 12:17:57 UTC
Pushed to autobuild-v4-0-test.
Comment 16 Karolin Seeger 2012-12-03 19:39:28 UTC
Pushed to v4-0-test.
Closing out bug report.

Thanks!