Bug 9337 - automount timeout caused by -I/
automount timeout caused by -I/
Status: RESOLVED DUPLICATE of bug 9339
Product: Samba 4.0
Classification: Unclassified
Component: Build
4.0.0rc3
All All
: P5 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
: 9163 (view as bug list)
Depends on: 9339
Blocks: 8622
  Show dependency treegraph
 
Reported: 2012-10-30 06:22 UTC by Andrew Bartlett
Modified: 2012-12-31 07:37 UTC (History)
3 users (show)

See Also:


Attachments
aviod -I/ by removing dep n PIDL_MISC (1.00 KB, patch)
2012-10-30 06:22 UTC, Andrew Bartlett
abartlet: review? (jelmer)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2012-10-30 06:22:57 UTC
Created attachment 8118 [details]
aviod -I/ by removing dep n PIDL_MISC

This patch avoids the build failures on hosts with automount support due to -I/ triggering an include of /net/fs.h
Comment 1 Michael Adam 2012-11-01 15:05:13 UTC
(In reply to comment #0)
> Created attachment 8118 [details]
> aviod -I/ by removing dep n PIDL_MISC
> 
> This patch avoids the build failures on hosts with automount support due to -I/
> triggering an include of /net/fs.h

The patch looks good and simple enough as such,
and I will happily ACK it if this is the way to go.

But for my understanding:
Don't we need the PIDL_MISC dependency?
Or the other way around: Why does PIDL_MISC add the "-I/"  (which looks strange to me)?

Cheers - Michael
Comment 2 Andrew Bartlett 2012-11-02 00:24:29 UTC
We seem to build fine without it, and I can't find even how it is declared.  It wasn't introduced with useful commit details, and I think it's simply a bug.
Comment 3 Stefan Metzmacher 2012-11-02 10:06:25 UTC
Comment on attachment 8118 [details]
aviod -I/ by removing dep n PIDL_MISC

This will be fixed as part of bug 9339
Comment 4 Michael Adam 2012-11-02 20:34:10 UTC
This patch has landed in v4-0-test as part of bug #9339.
Marking bug resolved duplicate for that reason.

*** This bug has been marked as a duplicate of bug 9339 ***
Comment 5 Andrew Bartlett 2012-12-31 07:37:39 UTC
*** Bug 9163 has been marked as a duplicate of this bug. ***