Bug 9232 - libnss-winbind.so is not building correctly under waf on non-linux platforms.
libnss-winbind.so is not building correctly under waf on non-linux platforms.
Status: RESOLVED DUPLICATE of bug 9339
Product: Samba 4.0
Classification: Unclassified
Component: Winbind
4.0.0rc1
All All
: P5 regression
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on: 9339
Blocks: 8622
  Show dependency treegraph
 
Reported: 2012-10-01 15:05 UTC by Ira Cooper
Modified: 2012-11-05 09:37 UTC (History)
2 users (show)

See Also:


Attachments
patch for master, fixes solaris. Applies clean against 4.0. (2.16 KB, application/octet-stream)
2012-10-01 15:05 UTC, Ira Cooper
abartlet: review-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ira Cooper 2012-10-01 15:05:25 UTC
Created attachment 7973 [details]
patch for master, fixes solaris.  Applies clean against 4.0.

On many non-linux platforms, libnss-winbind.so is broken.  (I do not have a full list, but I'd expect everything non-GNU.)

Debugging the issues this causes is confusing and painful to say the least, because the breakage causes an incorrect library to be built, and then the user is stuck scratching their head wondering why things like "id" don't work, and truss is really no help.  In master the included patch disabled building the library on platforms we haven't fixed it on.

That patch is included here, for your review, for 4.0.

If others would please help by fixing the platforms they have access to and verifying that the library works, I'd appreciate it.

Thanks,
Comment 1 Andrew Bartlett 2012-10-01 20:52:29 UTC
Comment on attachment 7973 [details]
patch for master, fixes solaris.  Applies clean against 4.0.

Patch breaks non-Linux GNU platforms, as it does not match the autoconf build info in source3/configure.in:5775
Comment 2 Andrew Bartlett 2012-10-18 07:11:17 UTC
Ira,

Can you grab the code from master, confirm it for Solaris and post a patch here?

it might/should be as simple as grabbing all these:

commit 1f267ca10e174ec3661631df2169e381136c2540
Author: Andrew Bartlett <abartlet@samba.org>
Date:   Tue Oct 2 08:12:16 2012 +1000

    nsswitch: Build nss_winbind on all supported platforms
    
    This matches what the autoconf build can do.
    
    Andrew Bartlett

commit 0e037bfc60162aa094df3e3cda59f7b9c2327ca9
Author: Andrew Bartlett <abartlet@samba.org>
Date:   Wed Oct 3 16:36:34 2012 +1000

    selftest: Always build a linux-style nss_winbind for nss_wrapper

commit 6dbe0aad260d1f6e46e58871a7ce613ca27d0bf6
Author: Ira Cooper <ira@samba.org>
Date:   Sun Sep 30 19:02:13 2012 +0000

    s3: Fix libnss_winbind.so's build on Illumos/Solaris
    
    Due to not building and linking in the winbind_nss_solaris bits in addition
    to the linux bits, nss was broken on Solaris.
    
    Autobuild-User(master): Ira Cooper <ira@samba.org>
    Autobuild-Date(master): Sun Sep 30 22:56:30 CEST 2012 on sn-devel-104
Comment 3 Andrew Bartlett 2012-11-04 22:09:56 UTC
Correct fix for this in in 9339 (build and quota fixes)
Comment 4 Michael Adam 2012-11-05 09:37:58 UTC
Fixed as part of bug #9339.
Hence marking fixed as duplicate.

*** This bug has been marked as a duplicate of bug 9339 ***