Bug 7997 - smb.conf.5 manpage truncated in 3.5.8
smb.conf.5 manpage truncated in 3.5.8
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Docs
3.5.8
All All
: P5 normal
: ---
Assigned To: Jelmer Vernooij
Samba Documentation QA Contact~
:
: 7990 7991 8029 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 19:19 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2011-10-08 18:57 UTC (History)
4 users (show)

See Also:


Attachments
patch for master (1.92 KB, patch)
2011-04-05 21:19 UTC, Michael Adam
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2011-03-09 19:19:31 UTC
IIRC, this happened once already, in the past:

bubulle@sesostris:~/src/debian/samba/svn/trunk/samba$ ls -l ../../../samba-3.5.6/docs/manpages/smb.conf.5 
-rw-r--r-- 1 bubulle bubulle 371037 18 juin   2010 ../../../samba-3.5.6/docs/manpages/smb.conf.5
bubulle@sesostris:~/src/debian/samba/svn/trunk/samba$ ls -l ../../../samba-3.5.8/docs/manpages/smb.conf.5 
-rw-r--r-- 1 bubulle bubulle 27249  6 mars  19:50 ../../../samba-3.5.8/docs/manpages/smb.conf.5
Comment 1 Guenther Deschner 2011-04-05 21:12:05 UTC
*** Bug 8029 has been marked as a duplicate of this bug. ***
Comment 2 Guenther Deschner 2011-04-05 21:13:51 UTC
Michael (obnox) seems to have nailed down the problem, when building docs we seem to have difficulties in checking timestamps of smb.conf.xml and the parameters folder. At least for fedora there is an updated package though.

Michael: is there a way to fix this properly upstream ?
Comment 3 Michael Adam 2011-04-05 21:19:04 UTC
Created attachment 6376 [details]
patch for master

Yes, the attached patch fixes the problem (for me).
The commit message also explains the problem more thoroughly.
I am about to push this to master.

Cheers - Michael
Comment 4 Guenther Deschner 2011-05-26 10:47:42 UTC
can this be closed as resolved then ?
Comment 5 Debian samba package maintainers (PUBLIC MAILING LIST) 2011-05-27 14:10:23 UTC
Before beging closed, shouldn't this be pushed to 3.5? Published 3.5.8 still has the problem. Assign to Karolin?
Comment 6 Michael Adam 2011-06-21 13:48:02 UTC
The 3.5.9 tarball is good.
But the patch has not been applied.
Broken manpages can be reproduced by doing

"touch docs-xml/manpages-3/smb.conf.5.xml"

prior to a build from a clean docs tree.
The attached patch reliably fixes it for me.
Comment 7 Michael Adam 2011-06-21 13:48:56 UTC
Comment on attachment 6376 [details]
patch for master

Patch applies cleanly to v3-5-test.
Comment 8 Michael Adam 2011-06-21 13:49:42 UTC
==> gd for review and please assign to Karo if patch is appropriate.
Comment 9 Guenther Deschner 2011-06-21 14:14:43 UTC
Comment on attachment 6376 [details]
patch for master

looks good
Comment 10 Guenther Deschner 2011-06-21 14:15:17 UTC
Karolin, please add to v3-5-test for the next 3.5.x update.
Comment 11 Karolin Seeger 2011-06-21 17:40:26 UTC
*** Bug 7990 has been marked as a duplicate of this bug. ***
Comment 12 Karolin Seeger 2011-06-21 17:42:44 UTC
*** Bug 7991 has been marked as a duplicate of this bug. ***
Comment 13 Karolin Seeger 2011-06-21 17:49:06 UTC
Strange, in bug #7991, I added another patch that fixed the issue for me.
That's a completely different approach.
I pushed Michael's fix now, but I would like Jelmer (or anyone else) to comment on the the patch:
https://attachments.samba.org/attachment.cgi?id=6579, please see  https://bugzilla.samba.org/show_bug.cgi?id=7991 for details).
Comment 14 Michael Adam 2011-06-21 19:38:24 UTC
(In reply to comment #13)
> Strange, in bug #7991, I added another patch that fixed the issue for me.
> That's a completely different approach.
> I pushed Michael's fix now, but I would like Jelmer (or anyone else) to comment
> on the the patch:
> https://attachments.samba.org/attachment.cgi?id=6579, please see 
> https://bugzilla.samba.org/show_bug.cgi?id=7991 for details).

Well, this must have been coincidence (or rather a combination of changed time stamps of files). The patch should have no reliable influence on the correct generation of the parameter descriptions:

As I wrote in comment #6, simply touching the smb.conf.5.xml file in a fresh checkout lets the docs build create the same incomplete manpage as before.

Creating a phony parameters target fixes this reliably.

Thanks for pushing the patch.

Cheers - Michael
Comment 15 Karolin Seeger 2011-10-08 18:57:52 UTC
Closing out bug report.