Bug 7326 - can't read/write any files with full_audit
can't read/write any files with full_audit
Product: Samba 3.4
Classification: Unclassified
Component: VFS Modules
x86 Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
: 6941 7035 7221 7353 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2010-04-05 01:20 UTC by Yury Tabolin
Modified: 2010-05-12 04:48 UTC (History)
4 users (show)

See Also:

smb.conf (2.85 KB, application/octet-stream)
2010-04-05 01:21 UTC, Yury Tabolin
no flags Details
log.smbd (27.31 KB, application/x-gzip)
2010-04-05 01:24 UTC, Yury Tabolin
no flags Details
Patch (1.43 KB, patch)
2010-04-05 07:50 UTC, Volker Lendecke
no flags Details
Changed proposed patch. (1.28 KB, patch)
2010-04-05 15:31 UTC, Jeremy Allison
no flags Details
git-am version of the same 3.4.x patch. (1.61 KB, patch)
2010-04-05 17:17 UTC, Jeremy Allison
vl: review+

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Tabolin 2010-04-05 01:20:17 UTC
When full_audit is used can't read/write any files in share. Navigating through folders on share are fine. The client WinXP when trying to read any file from share give a message "disk read error", but in the full_audit log written that access is successfull:

smbd_audit: user11|dmn-vmxp2|sendfile|ok|bdc/123.txt

When try to create and write a file, give message "Enough memory to process this command". In file writing of unreadable symbols. In full_audit log:

smbd_audit: user11|dmn-vmxp2|ftruncate|ok|bdc/12345.txt
smbd_audit: user11|dmn-vmxp2|ftruncate|ok|bdc/12345.txt
smbd_audit: user11|dmn-vmxp2|unlink|ok|bdc/TMP3.tmp
smbd_audit: user11|dmn-vmxp2|pwrite|ok|bdc/12345.txt

If comment full_audit strings in smb.conf, all OK.
vfs objects = full_audit
full_audit:prefix = %u|%m
full_audit:failure = none
full_audit:success = mkdir rmdir write pwrite rename ftruncate unlink read pread sendfile
full_audit:facility = local5
full_audit:priority = notice

Debian GNU/Linux 5.0
2.6.26-2-686 #1 SMP Wed Aug 19 06:06:52 UTC 2009 i686 GNU/Linux

ii  samba                             2:3.4.7~dfsg-1~bpo50+1
ii  samba-common                      2:3.4.7~dfsg-1~bpo50+1
ii  samba-common-bin                  2:3.4.7~dfsg-1~bpo50+1
ii  samba-doc                         2:3.4.7~dfsg-1~bpo50+1
ii  smbclient                         2:3.4.7~dfsg-1~bpo50+1
ii  smbfs                             2:3.4.7~dfsg-1~bpo50+1
ii  smbldap-tools                     0.9.4-1
ii  libcrypt-smbhash-perl             0.12-2
ii  mmc-web-samba                     2.3.2-1
ii  python-mmc-samba                  2.3.2-1
Comment 1 Yury Tabolin 2010-04-05 01:21:50 UTC
Created attachment 5592 [details]
Comment 2 Yury Tabolin 2010-04-05 01:24:03 UTC
Created attachment 5593 [details]
Comment 3 Volker Lendecke 2010-04-05 07:50:34 UTC
Created attachment 5594 [details]

The attached patch fixes it for me. Please test!

Comment 4 Jeremy Allison 2010-04-05 15:31:00 UTC
Created attachment 5595 [details]
Changed proposed patch.

I think this is a little more complete.
Comment 5 Volker Lendecke 2010-04-05 17:00:35 UTC
Comment on attachment 5595 [details]
Changed proposed patch.

If you add a commit message, it would probably right.

Comment 6 Jeremy Allison 2010-04-05 17:17:50 UTC
Created attachment 5596 [details]
git-am version of the same 3.4.x patch.
Comment 7 Volker Lendecke 2010-04-05 17:19:14 UTC
Comment on attachment 5596 [details]
git-am version of the same 3.4.x patch.

Thanks :-)
Comment 8 Volker Lendecke 2010-04-05 17:20:19 UTC
Karolin, this patch is required for 3.4.x, but we should wait for feedback by the reporter before closing the bug.

Comment 9 Yury Tabolin 2010-04-06 01:48:24 UTC
(In reply to comment #6)
> Created an attachment (id=5596) [details]
> git-am version of the same 3.4.x patch.

I tried the patch, everything worked perfectly. Thanks! Very quickly :)
Comment 10 Karolin Seeger 2010-04-06 02:16:58 UTC
Pushed patch to v3-4-test.
Closing out bug report.

Comment 11 Volker Lendecke 2010-04-08 04:08:14 UTC
*** Bug 7035 has been marked as a duplicate of this bug. ***
Comment 12 Volker Lendecke 2010-04-08 04:09:02 UTC
*** Bug 7221 has been marked as a duplicate of this bug. ***
Comment 13 Volker Lendecke 2010-05-03 03:48:21 UTC
*** Bug 6941 has been marked as a duplicate of this bug. ***
Comment 14 Karolin Seeger 2010-05-12 04:48:41 UTC
*** Bug 7353 has been marked as a duplicate of this bug. ***