Bug 7221 - vfs_full_audit completely does not work
vfs_full_audit completely does not work
Status: RESOLVED DUPLICATE of bug 7326
Product: Samba 3.4
Classification: Unclassified
Component: File services
3.4.6
x86 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-07 02:05 UTC by TAKAHASHI Motonobu
Modified: 2010-04-08 04:09 UTC (History)
0 users

See Also:


Attachments
log file / capture file / smbstatus result (123.12 KB, application/octet-stream)
2010-03-07 04:38 UTC, TAKAHASHI Motonobu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2010-03-07 02:05:19 UTC
When vfs_full_audit is enabled, we cannot read / write any files.
This behavior seems to differ from BUG#7035, BUG#6557.

My smb.conf:

-----
[global]

[homes]
  writeable = yes
  browseable = no
  vfs objects = full_audit
-----


Debug 10 log says nothing:

-----
[2010/03/07 09:50:47,  5] lib/debug.c:407(debug_dump_status)
  INFO: Current debug levels:
    all: True/10
(snip)
    registry: False/0
[2010/03/07 09:51:39, 10] lib/messages_local.c:73(messaging_tdb_signal_handler)
  messaging_tdb_signal_handler: sig[10] count[1] msgs[1]
[2010/03/07 09:51:39, 10] lib/messages_local.c:447(message_dispatch)
  message_dispatch: received_messages = 1
[2010/03/07 09:51:39, 10] lib/messages_local.c:196(messaging_tdb_fetch)
  messaging_tdb_fetch:
[2010/03/07 09:51:39,  1] ../librpc/ndr/ndr.c:214(ndr_print_debug)
       result: struct messaging_array
          num_messages             : 0x00000001 (1)
          messages: ARRAY(1)
              messages: struct messaging_rec
                  msg_version              : 0x00000002 (2)
                  msg_type                 : MSG_DEBUG (1)
                  dest: struct server_id
                      id                       : 0x00003e31 (15921)
                  src: struct server_id
                      id                       : 0x00003e55 (15957)
                  buf                      : DATA_BLOB length=2
[2010/03/07 09:51:39, 10] ../lib/util/util.c:304(_dump_data)
  [0000] 30 00                                             0.
[2010/03/07 09:51:39,  3] lib/debug.c:509(debug_message)
  INFO: Remote set of debug to `0'  (pid 15921 from pid 15957)
-----

Lokking at the output of smbstatus. there are lots of oplocks:

-----
lenny3:/usr/local/samba/var# ../bin/smbstatus  | head -20

Samba version 3.4.6
PID     Username      Group         Machine
-------------------------------------------------------------------
15931     local         local         medaka       (::ffff:192.168.135.1)

Service      pid     machine       Connected at
-------------------------------------------------------
IPC$         15931   medaka        Sun Mar  7 09:45:08 2010
local        15931   medaka        Sun Mar  7 09:45:12 2010

Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           Share
Path   Name   Time
--------------------------------------------------------------------------------
------------------
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   Work/samba-3.4.6/COPYING   Sun Mar  7 09:45:20 2010
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   Work/samba-3.4.6/COPYING   Sun Mar  7 09:45:20 2010
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   .bash_history   Sun Mar  7 09:45:13 2010
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   .bash_history   Sun Mar  7 09:45:13 2010
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   .bash_history   Sun Mar  7 09:46:55 2010
15931        1000       DENY_NONE  0x20080     RDONLY     NONE             /home
/local   .bash_history   Sun Mar  7 09:46:55 2010
-----
Comment 1 TAKAHASHI Motonobu 2010-03-07 02:23:03 UTC
Additional information:

Connecting from smbclient / Windows XP SP2, the problem does not occur.
Connecting from Windows XP SP3 / Windows 7, the problem does occur.
Comment 2 Volker Lendecke 2010-03-07 02:55:45 UTC
Sorry, this is too little information to reproduce the thing. Please upload a full debug level 10 log of smbd with this failure, together with a network trace. Please see http://wiki.samba.org/index.php/Capture_Packets for information on how to produce useful network traces.

Thanks,

Volker
Comment 3 TAKAHASHI Motonobu 2010-03-07 04:38:17 UTC
Created attachment 5468 [details]
log file / capture file / smbstatus result

log.smbd / packet capture / the output of smbstatus

situation:

Windows XP SP3 client (192.168.135.1)
Samba 3.4.6 server    (192.168.135.247)

(1) start smbd
(2) start capturing
(3) net start \\lenny3\local (as user:local)
(4) open dame.txt 
(5) run smbstatus
(6) error = 58 occurred 
(7) kill smbd
(8) stop capture

smb.conf:
-----
[global]
  dos charset = CP932
  unix charset = UTF-8
  workgroup = WORKGROUP
  passdb backend = tdbsam

[homes]
  writeable = yes
  browseable = no
  vfs objects = full_audit

There are several other shares.
-----

-----
lenny3:/usr/local/samba/var# ls -la /home/local
total 120
drwxr-xr-x 2 local local 94208 2010-03-07 19:37 .
drwxr-xr-x 7 root  root   4096 2010-03-07 11:29 ..
-rw------- 1 local local  3373 2010-03-07 10:33 .bash_history
-rw-r--r-- 1 local local   220 2008-02-10 07:32 .bash_logout
-rw-r--r-- 1 local local   414 2008-02-10 07:32 .bash_profile
-rw-r--r-- 1 local local  2227 2008-02-10 07:32 .bashrc
-rw-r--r-- 1 local root      5 2010-03-07 11:46 dame.txt
-----
Comment 4 Volker Lendecke 2010-04-08 04:09:02 UTC
Very likely a duplicate of bug 7326, please try the patch from there.

Volker

*** This bug has been marked as a duplicate of bug 7326 ***