Bug 6941 - VFS full_audit not work
VFS full_audit not work
Status: RESOLVED DUPLICATE of bug 7326
Product: Samba 3.4
Classification: Unclassified
Component: VFS Modules
3.4.3
x86 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-30 07:58 UTC by Felipe Domingos
Modified: 2010-05-03 03:48 UTC (History)
0 users

See Also:


Attachments
/var/log/samba/felipe.domingos.log (238.31 KB, text/plain)
2009-12-01 05:53 UTC, Felipe Domingos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Domingos 2009-11-30 07:58:18 UTC
The VFS full_audit not work for all files and stop the access server files with the messages in log:

Nov 30 11:50:27 smb smbd_audit[25283]: [2009/11/30 11:50:27,  0] smbd/oplock.c:317(oplock_timeout_handler)
Nov 30 11:50:27 smb smbd_audit[25283]:   Oplock break failed for file Novo(a) Documento de texto.txt -- replying anyway


share of smb.conf:

[Share]
        path = /data/public
        force user = %U      
        read only = No       
        veto files = /*.pst/*.pif/*.{*}/
        volume = Public                
        vfs objects = full_audit                                
        full_audit:facility = LOCAL5                            
        full_audit:priority = NOTICE                            
        full_audit:prefix = %u|%I|%S                 
        full_audit:success = unlink write
        full_audit:failure = none
Comment 1 Volker Lendecke 2009-11-30 08:37:29 UTC
Please upload the full level 10 smbd logfile.

Thanks,

Volker
Comment 2 Felipe Domingos 2009-11-30 11:02:12 UTC
(In reply to comment #1)
> Please upload the full level 10 smbd logfile.
> 
> Thanks,
> 
> Volker
> 

Hi,

/var/log/messages:

Nov 30 14:27:32 smb smbd_audit[25516]: connect to service IPC$ by user felipe.domingos
Nov 30 14:27:43 smb smbd_audit[25516]: disconnected

/var/log/syslog:

Nov 30 14:28:02 smb smbd_audit[25516]: [2009/11/30 14:28:02,  0] smbd/oplock.c:317(oplock_timeout_handler)
Nov 30 14:28:02 smb smbd_audit[25516]:   Oplock break failed for file Novo(a) Documento de texto.txt -- replying anyway

/var/log/samba/felipe.domingos.log is big so i can sent for one email?

tks
Comment 3 Volker Lendecke 2009-11-30 14:09:56 UTC
Is that really a debug level 10 log of smbd?

Please set "debug level = 10" in the section [global] of your smb.conf file which might typically be stored in /etc/samba/smb.conf. Then trigger the failure, the relevant log file is typically stored under /var/log/samba/log.smbd. Depending on your settings in your /etc/samba/smb.conf file (assuming it's stored there), the log file might also be stored somewhere else.

Thanks,

Volker
Comment 4 Felipe Domingos 2009-12-01 05:53:32 UTC
Created attachment 5031 [details]
/var/log/samba/felipe.domingos.log

This is /var/log/samba/felipe.domingos.log
Comment 5 Felipe Domingos 2009-12-01 05:54:47 UTC
(In reply to comment #3)
> Is that really a debug level 10 log of smbd?
> 
> Please set "debug level = 10" in the section [global] of your smb.conf file
> which might typically be stored in /etc/samba/smb.conf. Then trigger the
> failure, the relevant log file is typically stored under
> /var/log/samba/log.smbd. Depending on your settings in your /etc/samba/smb.conf
> file (assuming it's stored there), the log file might also be stored somewhere
> else.
> 
> Thanks,
> 
> Volker
> 


Hi, I change defaults log of smb.conf in [global] for:

        log level = 2
        debug level = 10
        log file = /var/log/samba/%U.log
        max log size = 1000000

So i think that log of my user is /var/log/samba/felipe.domingos.log 

Here is my new share for test:

[Publico]
        path = /dados/publico
        force user = %U
        read only = No
        create mask = 0777
        force create mode = 0777
        directory mask = 0777
        force directory mode = 02777
        veto files = /*.pst/*.pif/*.{*}/
        volume = Publico
        vfs objects = full_audit
        full_audit:prefix = %u|%I|%S
        full_audit:success = unlink write
        full_audit:failure = none

/var/log/samba/felipe.domingos.log in Attachment.

Tks,

Felipe
Comment 6 Volker Lendecke 2010-04-08 04:10:38 UTC
Highly likely a duplicate of bug 7326. Please try the patch from

https://bugzilla.samba.org/attachment.cgi?id=5596

Volker
Comment 7 Volker Lendecke 2010-05-03 03:48:21 UTC
Closing as a dup of 7326. Please re-open if 

https://bugzilla.samba.org/attachment.cgi?id=5596&action=view

does not fix it for you.

Volker

*** This bug has been marked as a duplicate of bug 7326 ***