Bug 328 - SWAT appends LDAP suffix twice
SWAT appends LDAP suffix twice
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.0preX
Other Linux
: P3 normal
: 3.0.1
Assigned To: John H Terpstra
:
: 385 555 611 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 01:15 UTC by Ulf Dettmer
Modified: 2005-08-24 10:17 UTC (History)
4 users (show)

See Also:


Attachments
Implement ldap sub-suffixes as per documentation (5.16 KB, patch)
2003-09-10 23:11 UTC, Tim Potter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf Dettmer 2003-08-20 01:15:42 UTC
I am using SuSE 8.2 and eDirectory 8.7 as passdb backend
These are the correct LDAP suffixes:

ldap suffix = ou=department,o=company,c=DE
ldap machine suffix = ou=server,ou=clients,ou=department,o=company,c=DE
ldap user suffix = ou=people,ou=department,o=company,c=DE
ldap group suffix = ou=group,ou=department,o=company,c=DE

As soon as I commit changes in SWAT  the ldap suffix is appended to all other 
suffixes a second time in my smb.conf:

ldap suffix = ou=department,o=company,c=DE
ldap machine suffix = 
ou=server,ou=clients,ou=department,o=company,c=DE,ou=department,o=company,c=DE
ldap user suffix = 
ou=people,ou=department,o=company,c=DE,ou=department,o=company,c=DE
ldap group suffix = 
ou=group,ou=department,o=company,c=DE,ou=department,o=company,c=DE
ldap idmap suffix = ou=department,o=company,c=DE,ou=department,o=company,c=DE

So I manually entered the other suffixes without 
the "ou=department,o=company,c=DE" part ( e.g. ou=group ) . Still, the smb.conf 
ends up with double ldap suffix appended two times when changes are comitted in 
SWAT.
Comment 1 Gerald (Jerry) Carter 2003-09-02 06:05:31 UTC
*** Bug 385 has been marked as a duplicate of this bug. ***
Comment 2 Tim Potter 2003-09-10 23:11:06 UTC
Created attachment 135 [details]
Implement ldap sub-suffixes as per documentation

I've submitted this patch to the samba-technical mailing list for review.  It
seems to fix your problem and also makes the various ldap suffix parameters
behave as documented.
Comment 3 Ulf Dettmer 2003-09-22 23:00:28 UTC
After more then a week of testing I can say this bug is FIXED for me. Thanks !
Comment 4 Gerald (Jerry) Carter 2003-10-07 11:09:19 UTC
*** Bug 555 has been marked as a duplicate of this bug. ***
Comment 5 Tim Potter 2003-10-13 18:20:44 UTC
*** Bug 611 has been marked as a duplicate of this bug. ***
Comment 6 Gerald (Jerry) Carter 2003-11-21 11:10:39 UTC
modifying tim's patch a bit to 
maintain the current behavior
Comment 7 Gerald (Jerry) Carter 2005-02-07 09:05:51 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:17:11 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.