Bug 555 - LDAP suffixes added repeatedly in SWAT
LDAP suffixes added repeatedly in SWAT
Status: RESOLVED DUPLICATE of bug 328
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
All Linux
: P3 regression
: none
Assigned To: John H Terpstra
Depends on:
  Show dependency treegraph
Reported: 2003-10-02 10:32 UTC by J B Bell
Modified: 2003-10-07 11:09 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description J B Bell 2003-10-02 10:32:09 UTC
I am using the Redhat 9 source RPM of samba 3.0.0.  I modified the spec file to
configure --with-ldapsam in order to work with our LDAP backend.

When I set an ldap suffix in the SWAT interface (global settings), in some
circumstances, that suffix ends up added again everytime I load the SWAT page. 
The settings are not actually in the file, but of course a commit will add them.
 The workaround is to manually re-set all the ldap suffixes before committing
the global settings in SWAT.  Obviously, this defeats the purpose of SWAT.

I suspect this is to do with loadparm.c's handle_ldap_suffix(), but I'm afraid
my C-fu is weak.
Comment 1 Gerald (Jerry) Carter 2003-10-07 11:09:18 UTC

*** This bug has been marked as a duplicate of 328 ***