Bug 611 - duplicately added ldap_suffix to ldap parameters
duplicately added ldap_suffix to ldap parameters
Status: RESOLVED DUPLICATE of bug 328
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.0
All All
: P3 normal
: none
Assigned To: John H Terpstra
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 09:36 UTC by TAKAHASHI Motonobu
Modified: 2003-10-13 18:20 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2003-10-13 09:36:57 UTC
If we use SWAT to set LDAP parameters , 
the value of "ldap suffix" parameter is duplicately added
to "ldap * suffix" parameters like

	ldap suffix = dc=home,dc=monyo,dc=com
	ldap machine suffix = 
ou=Computers,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc
=com,dc=home,dc=monyo,dc=com
	ldap user suffix = 
ou=Users,dc=home,dc=monyo,dc=com,ou=Users,dc=home,dc=monyo,dc=com,dc=home,dc=mon
yo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=co
m,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=hom
e,dc=monyo,dc=com
	ldap group suffix = 
ou=Groups,dc=home,dc=monyo,dc=com,ou=Users,dc=home,dc=monyo,dc=com,dc=home,dc=mo
nyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=c
om,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=ho
me,dc=monyo,dc=com
	ldap idmap suffix = 
ou=Users,dc=monyo,dc=com,ou=Users,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=co
m,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=hom
e,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=monyo,dc=com,dc=home,dc=mon
yo,dc=com

Maybe This is bug for handle_ldap_sub_suffix and handle_ldap_suffix in 
loadparm.c.
Comment 1 Tim Potter 2003-10-13 18:20:42 UTC

*** This bug has been marked as a duplicate of 328 ***