Bug 1644 - smbd in 3.0.3 or later not showing (printer?) shares with >=13 char names in share list
smbd in 3.0.3 or later not showing (printer?) shares with >=13 char names in ...
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.6
All Linux
: P4 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
: 1334 1742 2136 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-21 13:36 UTC by Buchan Milne
Modified: 2005-02-03 07:28 UTC (History)
3 users (show)

See Also:


Attachments
CUPS printer configuration file (/etc/cups/printers.conf) (914 bytes, text/plain)
2004-08-21 13:39 UTC, Buchan Milne
no flags Details
Samba configuration file (21.75 KB, text/plain)
2004-08-21 13:45 UTC, Buchan Milne
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buchan Milne 2004-08-21 13:36:11 UTC
This may be related to bug 1464.

In samba >= 3.0.3, when samba is compiled against recent cups, and with:

load printers = yes
printing = cups
printcap name = cups

samba does not expose the last CUPS printer. For example:

[bgmilne@comanche bgmilne]$ lpstat -t
scheduler is running
system default destination: telkom_hp2100
device for hp1300_home: ipp://192.168.1.1:631/printers/hp1300
device for hp3700dn: socket://hp3700dn.obsidian.co.za:9100/
device for hp3700n: socket://hp3700n.obsidian.co.za:9100/
device for telkom_hp2100: socket://192.168.0.27:9100/
hp1300_home accepting requests since Jan 01 00:00
hp3700dn accepting requests since Jan 01 00:00
hp3700n accepting requests since Jan 01 00:00
telkom_hp2100 accepting requests since Jan 01 00:00
printer hp1300_home is idle.  enabled since Jan 01 00:00
printer hp3700dn is idle.  enabled since Jan 01 00:00
printer hp3700n is idle.  enabled since Jan 01 00:00
printer telkom_hp2100 is idle.  enabled since Jan 01 00:00
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[RANGER] OS=[Unix] Server=[Samba 3.0.6]
Domain=[RANGER] OS=[Unix] Server=[Samba 3.0.6]
        hp1300_home     Printer   HP LaserJet 1300
        hp3700dn        Printer   HP color LaserJet 3700
        hp3700n         Printer   HP color LaserJet 3700
[bgmilne@comanche bgmilne]$

All printers are on "local" cups queues, against the local CUPS server.

Printing works correctly in 3.0.2a ... but nothing after that:
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.2a]
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.2a]
        pdf-generator  Printer   PDF Generator (only valid users)
        hp1300_home    Printer   HP LaserJet 1300
        hp3700dn       Printer   HP color LaserJet 3700
        hp3700n        Printer   HP color LaserJet 3700
        telkom_hp2100  Printer   HP LaserJet 2100
[bgmilne@comanche bgmilne]$ urpmi samba-server-3.0.3
To satisfy dependencies, the following packages are going to be installed (19 MB):
samba-client-3.0.3-2mdk.i586
samba-common-3.0.3-2mdk.i586
samba-server-3.0.3-2mdk.i586
Is this OK? (Y/n) y

installing
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-server-3.0.3-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-client-3.0.3-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-common-3.0.3-2mdk.i586.rpm
Preparing...                ##################################################
   1:samba-common           ##################################################
   2:samba-server           ##################################################
   3:samba-client           ##################################################
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.3]
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.3]
        hp1300_home     Printer   HP LaserJet 1300
        hp3700dn        Printer   HP color LaserJet 3700
        hp3700n         Printer   HP color LaserJet 3700
[bgmilne@comanche bgmilne]$ urpmi samba-server-3.0.4
To satisfy dependencies, the following packages are going to be installed (19 MB):
samba-client-3.0.4-2mdk.i586
samba-common-3.0.4-2mdk.i586
samba-server-3.0.4-2mdk.i586
Is this OK? (Y/n) y

installing
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-client-3.0.4-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-common-3.0.4-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-server-3.0.4-2mdk.i586.rpm
Preparing...                ##################################################
   1:samba-common           ##################################################
   2:samba-client           ##################################################
   3:samba-server           ##################################################
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.4]
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.4]
        hp1300_home     Printer   HP LaserJet 1300
        hp3700dn        Printer   HP color LaserJet 3700
        hp3700n         Printer   HP color LaserJet 3700
[bgmilne@comanche bgmilne]$ urpmi samba-server-3.0.5
To satisfy dependencies, the following packages are going to be installed (19 MB):
samba-client-3.0.5-2mdk.i586
samba-common-3.0.5-2mdk.i586
samba-server-3.0.5-2mdk.i586
Is this OK? (Y/n) y

installing
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-common-3.0.5-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-client-3.0.5-2mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-server-3.0.5-2mdk.i586.rpm
Preparing...                ##################################################
   1:samba-common           ##################################################
   2:samba-client           ##################################################
   3:samba-server           ##################################################
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.5]
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.5]
        hp1300_home     Printer   HP LaserJet 1300
        hp3700dn        Printer   HP color LaserJet 3700
        hp3700n         Printer   HP color LaserJet 3700
[bgmilne@comanche bgmilne]$ urpmi samba-server-3.0.6
To satisfy dependencies, the following packages are going to be installed (20 MB):
samba-client-3.0.6-1.1000mdk.i586
samba-common-3.0.6-1.1000mdk.i586
samba-server-3.0.6-1.1000mdk.i586
Is this OK? (Y/n) y

installing
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-server-3.0.6-1.1000mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-client-3.0.6-1.1000mdk.i586.rpm
/home/bgmilne/rpm/mdk/RPMS.mdk10.0/./i586/samba-common-3.0.6-1.1000mdk.i586.rpm
Preparing...                ##################################################
   1:samba-common           ##################################################
   2:samba-server           ##################################################
   3:samba-client           ##################################################
[bgmilne@comanche bgmilne]$ smbclient -L localhost -N|grep Printer
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.6]
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.6]
        hp1300_home     Printer   HP LaserJet 1300
        hp3700dn        Printer   HP color LaserJet 3700
        hp3700n         Printer   HP color LaserJet 3700
[bgmilne@comanche bgmilne]$


It seems there may be more problems here as well, the printer defined in a print
share (pdf-generator that appears in the 3.0.2a output) goes awol too.

I am using the default configs on Mandrake (ie basically those in
packaging/Mandrake) for these tests.

(I can't ship samba updates which introduce this regression ...)
Comment 1 Buchan Milne 2004-08-21 13:39:19 UTC
Created attachment 609 [details]
CUPS printer configuration file (/etc/cups/printers.conf)
Comment 2 Buchan Milne 2004-08-21 13:45:03 UTC
Created attachment 610 [details]
Samba configuration file

Example smb.conf used for the last output with 3.0.6 (from 3.0.2a to 3.0.6 the
default Mandrake smb.conf was used - which may differ slightly between versions
but should not affect printing).
Comment 3 Gerald (Jerry) Carter 2004-08-26 15:30:29 UTC
ok.  I'm convinced.  Can't reproduce it though.  But I'm working on it.
Comment 4 Gerald (Jerry) Carter 2004-08-27 10:10:08 UTC
Reproduced it and there is no bug here.  The missing printers 
(there are 2 actually...you forgot about the pdf-generator)
have sharenamse > 12 characters so will not be available via 
RAP.  The shares with long names are available from 
clients >= Windows NT.

Closing as invalid.
Comment 5 Gerald (Jerry) Carter 2004-08-27 10:11:52 UTC
*** Bug 1334 has been marked as a duplicate of this bug. ***
Comment 6 Buchan Milne 2004-08-31 13:58:58 UTC
As discussed by email, this bug still seems valid, with a different description.
Comment 7 Gerald (Jerry) Carter 2004-08-31 14:23:51 UTC
----- Comments from Buchan via email -----

Hmm, it seems it's just that smbd >= 3.0.2a won't list 
>=13 character shares to smbclient:

[root@comanche bgmilne]# smbclient -V
Version 3.0.6
[root@comanche bgmilne]# smbclient -L one4all -N
Domain=[ONE4ALL] OS=[Unix] Server=[Samba 3.0.2a]

        Sharename       Type      Comment
        ---------       ----      -------
        print$          Disk
        pdf-generator   Printer   PDF Generator (only valid users)
        IPC$            IPC       IPC Service (Samba Server 3.0.2a)
        ADMIN$          IPC       IPC Service (Samba Server 3.0.2a)
        laser           Printer   HP 1100

[root@comanche bgmilne]# smbclient -L localhost -N
Anonymous login successful
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.6]

        Sharename       Type      Comment
        ---------       ----      -------
        print$          Disk
        pdf-gen         Printer   PDF Generator (only valid users)
        IPC$            IPC       IPC Service (Samba Server 3.0.6)
        ADMIN$          IPC       IPC Service (Samba Server 3.0.6)
        laser           Printer   HP 1100

[bgmilne@comanche bgmilne]$ testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[pdf-gen]"
Processing section "[pdf-generator]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE


So, the pdf-generator share is not displayed when the 
server is running 3.0.6, but it is under 3.0.2a (and 
I didn't see an explanation for it ...). It does work 
(ie smbclient //localhost/pdf-generator -c 
'print /etc/fstab') though ...



[root@one4all bgmilne]# smbclient -V
Version 3.0.2a
[root@one4all bgmilne]# smbclient -L localhost -N
Domain=[ONE4ALL] OS=[Unix] Server=[Samba 3.0.2a]

        Sharename      Type      Comment
        ---------      ----      -------
        print$         Disk
        pdf-generator  Printer   PDF Generator (only valid users)
        IPC$           IPC       IPC Service (Samba Server 3.0.2a)
        ADMIN$         IPC       IPC Service (Samba Server 3.0.2a)
        laser          Printer   HP 1100

[root@one4all bgmilne]# smbclient -L comanche -N -I 192.168.3.156
Anonymous login successful
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.6]

        Sharename      Type      Comment
        ---------      ----      -------
        print$         Disk
        pdf-gen        Printer   PDF Generator (only valid users)
        IPC$           IPC       IPC Service (Samba Server 3.0.6)
        ADMIN$         IPC       IPC Service (Samba Server 3.0.6)
        laser          Printer   HP 1100

But, I may have been misled by this changelog 
entry for 3.0.3:

o   Chris Hertel <crh@samba.org>
    * fix enumeration of shares 12 characters 
      in length via smbclient.

I still think something is wrong here ... which worked on 
3.0.2a and has stopped working without explanation ...

Unfortunately I can't really test from a Windows 
client right now ... 
Comment 8 Gerald (Jerry) Carter 2004-09-09 06:32:10 UTC
*** Bug 1742 has been marked as a duplicate of this bug. ***
Comment 9 Florian Effenberger 2004-09-09 08:23:29 UTC
Bug is here as well.
If there is anything I can send you in order to help you debugging it, please 
let me know.
Comment 10 Gerald (Jerry) Carter 2004-12-08 10:02:51 UTC
*** Bug 2136 has been marked as a duplicate of this bug. ***
Comment 11 Buchan Milne 2004-12-14 00:23:16 UTC
Jerry, is this going to be looked at, or should I start filing bugs on our
printer configuration software to generate at most 12 letter printer names
(unfortunately HPDeskJetXXXX and HPLaserJetXXXX happen to be just too long ...).

(see for example http://qa.mandrakesoft.com/show_bug.cgi?id=12667)
Comment 12 Gerald (Jerry) Carter 2004-12-16 12:40:44 UTC
I think its lower priority than some.  If you can convince me that Windows
does this differently then, it will get more attention.
Comment 13 Gerald (Jerry) Carter 2005-02-03 07:28:51 UTC
Buchan, I think the best thing if you haven't already 
is to modify your printer driver configureation software.
I doubt we'll change this unless a lot of people scream and
show us that we do something different than Windows 
for the RAP call.