Bug 1334 - printer with a too long name is not accepted
printer with a too long name is not accepted
Status: RESOLVED DUPLICATE of bug 1644
Product: Samba 3.0
Classification: Unclassified
Component: Printing
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2004-05-09 14:10 UTC by Michael Braun
Modified: 2004-08-27 10:11 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Braun 2004-05-09 14:10:31 UTC

I've got a "HP Deskjet 656c" printer at USB and I'm using SuSE 9.0 with Samba 3.0.3.
I used YaST to configurate the printer with CUPS and added the queue named
Although I could print from cups and I could install a network printer on my
windows system (with the URI \\host\hp_deskjet656c), the printer has neigher
been shown in the list of shares nor as a printer when I accessed
\\host\hp_deskjet656c with the windows explorer.
Printing directly was successfull, the printer queue has been displayed in the
windows printer dialog.
I restartet samba, cups and finally restartet also the whole computer, but the
problem did not go away, nor could the problem be solved by reconfigurating the
printer using the cups web interface or adding manually a printer share in smb.conf.
An other printer, called hp520, instead, was displayed correctly and could also
be used.
The problem could be solved by renaming the hp_deskjet656c printer to deskjet656c.
Neighter hpdeskjet656c nor something like that worked, but deskjet656c did.
As I could see in the log of the smbd saying 

[2004/05/09 22:20:23, 5] printing/print_cups.c:cups_printer_fn(93)
[2004/05/09 22:20:23, 3] param/loadparm.c:lp_add_printer(2401)
  adding printer service hp520
[2004/05/09 22:20:23, 3] param/loadparm.c:lp_add_printer(2401)
  adding printer service hp_deskjet656c

I'm sure that it is probably not the fault of cups, so I'm thinking of samba.
The queue has not been displayed by using smbclient, LinNeightborhood or Windows
 98/Me/2k, so it's probably the server's fault.

Comment 1 Gerald (Jerry) Carter 2004-08-27 10:11:50 UTC
I'm pretty sure this is a duplicate of 1644.

*** This bug has been marked as a duplicate of 1644 ***