Bug 932 - password not changed with pam_smbpasswd migrate
password not changed with pam_smbpasswd migrate
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.1
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
http://www.holeschak.de
:
: 719 779 (view as bug list)
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2004-01-01 08:14 UTC by Ulrich Holeschak
Modified: 2005-11-14 09:24 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Holeschak 2004-01-01 08:14:49 UTC
Hello,
when using pam_smbpasswd only an empty password with XXX is created in the 
smbpasswd file when using the migration function. (With samba 2.2 this was OK).
If have fixed this in changing the following line in pam_smb_auth.c (Function 
_smb_add_user)
---------------------------
        retval = local_password_change( name, LOCAL_ADD_USER,
                                         pass, err_str,
                                         sizeof(err_str),
                                         msg_str, sizeof(msg_str) );
---------------------------
to 
---------------------------
        retval = local_password_change( name, LOCAL_ADD_USER | 
LOCAL_SET_PASSWORD,
                                         pass, err_str,
                                         sizeof(err_str),
                                         msg_str, sizeof(msg_str) );
---------------------------
Now the correct password entry is created in the smbpasswd file.
Is this modification OK?

Ulrich
Comment 1 Gerald (Jerry) Carter 2004-03-18 06:44:14 UTC
*** Bug 779 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2004-03-18 09:55:53 UTC
*** Bug 719 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2004-03-18 10:10:36 UTC
Looks right to me.  Applying.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:15:49 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:24:37 UTC
database cleanup