Bug 719 - pam_smbpass doesn't work in 3.0.x; 2.2.8a is ok
pam_smbpass doesn't work in 3.0.x; 2.2.8a is ok
Status: RESOLVED DUPLICATE of bug 932
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Depends on:
  Show dependency treegraph
Reported: 2003-11-05 05:29 UTC by Bernhard Rosenkraenzer
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:

system-auth sample file (1.10 KB, text/plain)
2003-11-05 05:30 UTC, Bernhard Rosenkraenzer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2003-11-05 05:29:12 UTC
[Component for pam_smbpass is missing in bugzilla btw] 
When upgrading a system that uses pam_smbpass to sync Unix passwords with 
samba passwords to samba 3.0.x (tried 3.0.0 and 3.0.1pre1), simple tasks like 
changing passwords fail. 
I'm attaching a sample pam.d/system-auth file to simplify reproducing the 
Reverting back to 2.2.8a "fixes" the problem.
Comment 1 Bernhard Rosenkraenzer 2003-11-05 05:30:15 UTC
Created attachment 240 [details]
system-auth sample file

Example pam config file to help reproducing the problem
Comment 2 Gerald (Jerry) Carter 2004-03-18 09:55:52 UTC

*** This bug has been marked as a duplicate of 932 ***
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:26:23 UTC
database cleanup