Bug 8447 - RHEL 5.7/Fedora 15 - "make quicktest" failures
RHEL 5.7/Fedora 15 - "make quicktest" failures
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
: 8415 8485 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-08 23:55 UTC by Ian Kaney
Modified: 2011-11-02 15:43 UTC (History)
2 users (show)

See Also:


Attachments
Console Output (50.19 KB, text/plain)
2011-09-08 23:55 UTC, Ian Kaney
no flags Details
config.h (31.53 KB, text/plain)
2011-09-09 00:14 UTC, Ian Kaney
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Kaney 2011-09-08 23:55:45 UTC
Created attachment 6873 [details]
Console Output

As per summary, follow steps as per wiki, RHEL 5.7 machine, 6 failures are shown. Find attached the console output.
Comment 1 Ian Kaney 2011-09-09 00:14:14 UTC
Created attachment 6874 [details]
config.h
Comment 2 Matthias Dieter Wallnöfer 2011-09-12 17:55:58 UTC
*** Bug 8415 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Dieter Wallnöfer 2011-10-13 08:02:16 UTC
*** Bug 8485 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Dieter Wallnöfer 2011-10-20 18:16:08 UTC
Andrew Bartlett answered this on the mailing list when discussing a similar issue:

> The challenge appears to be to do with the packages that are installed
> on the system.  For example, I have been unable to replicate this on my
> Centos 5 system, despite this being listed as a 'failing' platform, and
> clearly it passes autobuild and runs on various developer machines.

> What we have not pinned down is what the missing package is, what
> difference that makes in terms of config.h, and then to disable the
> tests that cannot run without that support compiled in.  You will see
> that tests.py attempts to skip certain tests if various config.h values
> are not found, but this clearly isn't enough.

> Perhaps you might be able to collect some config.h examples, and compare
> against your system where this presumably passes?  That might help
> create the right patches for tests.py

> Andrew Bartlett

So reporters, did you all make sure that you have no outdated packages installed (talloc, tdb, ldb...)? If no we need to analyse this further.
Comment 5 Martijn de Jong 2011-10-20 18:36:58 UTC
My test was with Fedora 15 installed with desktop and all the latest updates. My Fedora 15 x64 server also is fully up to date, with a complete development environment installed and still gives the same errors on compiling Samba. It's therefore definitely not a case of outdated packages.
It would be interesting to see a list of required packages. Instead of Samba skipping things because the required packages are not installed, I would prefer to simply install those required packages.
Comment 6 Andrew Bartlett 2011-10-28 21:27:42 UTC
Please retry with current git, as this may have just been an smbd bug, shown up due the the particular circumstances in which this was run.

A fix for a very similar issue is in the tree now as 
http://gitweb.samba.org/?p=samba.git;a=commitdiff;h=8c6ff21782b141571dde64e80cc42540e9177a23

Sorry for the bother!
Comment 7 Martijn de Jong 2011-10-30 12:27:26 UTC
That did the trick. Make quicktest now finishes with All Ok. Thanks!
Comment 8 Matthias Dieter Wallnöfer 2011-11-02 15:43:06 UTC
Marking as "FIXED". If the problem or part of it persists please reopen.