Bug 7044 - Replication problem with Windows Server 2003
Replication problem with Windows Server 2003
Status: RESOLVED DUPLICATE of bug 6738
Product: Samba 4.0
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on: 6714 6738
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-15 09:28 UTC by Mohammad Nazeem Durgahee
Modified: 2010-01-31 04:03 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad Nazeem Durgahee 2010-01-15 09:28:27 UTC
I vampire s4 to s4 to get replication which work fine then used dcpromo to add a third DC which is Windows 2003 standard edition with service pack2. Then I have to change the one of the S4 to global catalog and the windows 2003 to global catalog as when as samba4 seems to compile as a global catalog server by default. But when I run dcdiag one the windows server this the result I get:
Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\BLU2
      Starting test: Connectivity
         ......................... BLU2 passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\BLU2
      Starting test: Replications
         ......................... BLU2 passed test Replications
      Starting test: NCSecDesc
         ......................... BLU2 passed test NCSecDesc
      Starting test: NetLogons
         Unable to connect to the NETLOGON share! (\\BLU2\netlogon)
         [BLU2] An net use or LsaPolicy operation failed with error 1203, Win32
Error 1203.
         ......................... BLU2 failed test NetLogons
      Starting test: Advertising
         Warning: DsGetDcName returned information for \\blu.replication.net, wh
en we were trying to reach BLU2.
         Server is not responding or is not considered suitable.
         [BLU] Warning: Root DSE attribute isGlobalCatalogReady is missing
         ......................... BLU2 failed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... BLU2 passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... BLU2 passed test RidManager
      Starting test: MachineAccount
         ......................... BLU2 passed test MachineAccount
      Starting test: Services
         ......................... BLU2 passed test Services
      Starting test: ObjectsReplicated
         ......................... BLU2 passed test ObjectsReplicated
      Starting test: frssysvol
         ......................... BLU2 passed test frssysvol
      Starting test: frsevent
         ......................... BLU2 passed test frsevent
      Starting test: kccevent
         ......................... BLU2 passed test kccevent
      Starting test: systemlog
         ......................... BLU2 passed test systemlog
      Starting test: VerifyReferences
         ......................... BLU2 passed test VerifyReferences

   Running partition tests on : Schema
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom

   Running partition tests on : Configuration
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom

   Running partition tests on : replication
      Starting test: CrossRefValidation
         ......................... replication passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... replication passed test CheckSDRefDom

   Running enterprise tests on : replication.net
      Starting test: Intersite
         ......................... replication.net passed test Intersite
      Starting test: FsmoCheck
         ......................... replication.net passed test FsmoCheck
Blu2 test to netlogon fails and also it fails to advertise the server as global catalog server can u plz look into it for me. Furthermore ntp is not giving the right time to windows DC it is getting invalid time. Thanks
Comment 1 Mohammad Nazeem Durgahee 2010-01-15 09:32:00 UTC
Furthermore I just doing a simple git checkout which is git clone git://git.samba.org/samba.git samba4. thus I am using samba4 pre-alpha 12.

Comment 2 Matthias Dieter Wallnöfer 2010-01-21 01:49:37 UTC
Tridge (or abartlet), you as replication export do you have a clue on this?
Comment 3 Mohammad Nazeem Durgahee 2010-01-21 09:07:23 UTC
The only reason for this that i found during the last couple of days is DFS and FRS is not yet implemented in Samba4 that is why I am getting this problem. As without one of these two protocals working we cannot have sysvol replication this is the master folder for sysvol. Hence group policy will also fail. I no the samba4 team is working on it and I donnot no when it will be ready. 
Comment 4 Matthias Dieter Wallnöfer 2010-01-24 04:31:55 UTC
Yeah, the implementation of DFS and/or FRS will be challenging. Any external help will be greatly appreciated to speed the implementation process up!
Comment 5 Mohammad Nazeem Durgahee 2010-01-24 06:59:25 UTC
I can help in testing as i am not very good in programming as I deal only with hardware and networking but as far as I know frs uses naerly the same process as DRS replication. It use the same channel to replicate sysvol as far as dfs I donot no hw it work but I do some research on both  protocols and come to you guys
Comment 6 Matthias Dieter Wallnöfer 2010-01-31 04:03:34 UTC
Okay, Mohammed - then let us close this since we have already feature requests for FRS/DFS implementation. Consider the two dependencies.

Well, on "mark as duplicate of bug" I can only specify one bug - but in reality it is a duplicate of both.

*** This bug has been marked as a duplicate of bug 6738 ***