Bug 669 - rpc modules not being recognized on solaris
rpc modules not being recognized on solaris
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
Other other
: P1 normal
: 3.0.1
Assigned To: Jelmer Vernooij
:
: 513 536 731 (view as bug list)
Depends on: 374
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-10-22 09:28 UTC by Gerald (Jerry) Carter
Modified: 2004-02-19 09:02 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald (Jerry) Carter 2003-10-22 09:28:31 UTC
(based on these entries form config.log):

~ configure:30793: checking how to build rpc_lsa
~ configure:30824: result: not
~ configure:30829: checking how to build rpc_reg
~ configure:30860: result: not
~ configure:30865: checking how to build rpc_lsa_ds
~ configure:30896: result: not
~ configure:30901: checking how to build rpc_wks
~ configure:30932: result: not
~ configure:30937: checking how to build rpc_net
~ configure:30968: result: not

I've seen this reported by a couple of people and
my only guess is that the elif is failing here:

AC_DEFUN(SMB_MODULE,
[
~        AC_MSG_CHECKING([how to build $1])
~        if test "$[MODULE_][$1]"; then
~                DEST=$[MODULE_][$1]
~        elif test "$[MODULE_]translit([$4], [A-Z], [a-z])"
~           -a "$[MODULE_DEFAULT_][$1]"; then
~                DEST=$[MODULE_]translit([$4], [A-Z], [a-z])
~        else
~                DEST=$[MODULE_DEFAULT_][$1]
~        fi


~From config.status:

configured by ./configure, generated by GNU Autoconf 2.53,
~  with options \"'--prefix=/tool/local'
~ '--exec_prefix=/tool/local/sunos-5-sparc' '--sysconfdir=/etc/samba'
~ '--with-swatdir=/tool/local/sunos-5-sparc/swat' '--localstatedir=/var'
~ '--with-smbwrapper' '--with-automount' '--with-configdir=/etc/samba'
~ '--with-logfilebase=/var/log' '--enable-cups' '--with-acl-support'
~ '--with-privatedir=/etc/samba/private'
~ '--with-lockdir=/var/spool/locks'
~ '--with-piddir=/var/spool/locks'
~ '--with-readline=/tool/local/sunos-5-sparc/lib' '--with-pam'
~ '--with-pam_smbpass' '--with-libsmbclient' '--with-winbind'
~ '-with-utmp'
~ '--with-msdfs' '--with-quotas' 'CFLAGS=-I/tool/local/cups/include
~ -I/tool/local/include -L/tool/local/cups/sunos-5-sparc/lib -Wl,-rpath
~ -Wl,/tool/local/cups/sunos-5-sparc/lib
~ -L/tool/local/sunos-5-sparc/lib'\"


~From the generated Makefile:

~  RPC_SERVER_OBJ =  $(RPC_SVC_OBJ) $(RPC_SPOOLSS_OBJ) $(RPC_PIPE_OBJ)
Comment 1 Gerald (Jerry) Carter 2003-11-30 21:04:21 UTC
*** Bug 731 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2003-12-07 22:54:33 UTC
*** Bug 513 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2003-12-08 06:07:13 UTC
*** Bug 536 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2003-12-08 10:01:25 UTC
I've reproduced this!  Whoop!  Thanks to Brian Dudek for 
the inspiration in bug 374.  Make sure that /usr/ucb does 
not precede /bin & /usr/bin in you PATH.