Bug 731 - Samba fails to compile on a Solaris 8 X86 platform
Samba fails to compile on a Solaris 8 X86 platform
Status: RESOLVED DUPLICATE of bug 669
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
All Solaris
: P3 normal
: none
Assigned To: Tim Potter
Depends on:
  Show dependency treegraph
Reported: 2003-11-07 00:22 UTC by Suresh Khatry
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Suresh Khatry 2003-11-07 00:22:07 UTC
Samba fails to compile on a Solaris 8 X86 platform.  I get the following error.
Am using GCC 2.95.3

Linking bin/smbd
Undefined                       first referenced
 symbol                             in file
lsa_ds_get_pipe_fns                 rpc_server/srv_pipe.o
samr_get_pipe_fns                   rpc_server/srv_pipe.o
lsa_get_pipe_fns                    rpc_server/srv_pipe.o
reg_get_pipe_fns                    rpc_server/srv_pipe.o
netlog_get_pipe_fns                 rpc_server/srv_pipe.o
wkssvc_get_pipe_fns                 rpc_server/srv_pipe.o
netdfs_get_pipe_fns                 rpc_server/srv_pipe.o
ld: fatal: Symbol referencing errors. No output written to bin/smbd
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `bin/smbd'
Comment 1 Gerald (Jerry) Carter 2003-11-30 21:04:20 UTC

*** This bug has been marked as a duplicate of 669 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:24:34 UTC
database cleanup