Bug 513 - make fails on IRIX 6.3 gcc 3.2.2
make fails on IRIX 6.3 gcc 3.2.2
Status: RESOLVED DUPLICATE of bug 669
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
SGI IRIX
: P1 regression
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-25 22:43 UTC by Randy Davis
Modified: 2003-12-07 22:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randy Davis 2003-09-25 22:43:14 UTC
samba 3.0.0 fails during make on IRIX 6.3 with gcc 3.2.2.  Configure runs 
normally, and make runs normally, until the final linker:

$ make
Using FLAGS =  -g -O2 -I./popt -Iinclude -I/usr2/admin/src/network/samba-
3.0.0/source/include -I/usr2/admin/src/network/samba-3.0.0/source/ubiqx -
I/usr2/admin/src/network/samba-3.0.0/source/smbwrapper  -I.  -
I/usr2/admin/src/network/samba-3.0.0/source
      LIBS = -lgen -liconv
      LDSHFLAGS = -set_version sgi1.0 -shared
      LDFLAGS =
Linking bin/smbd
ld32: WARNING 84 : /usr/lib32/libgen.so is not used for resolving any symbol.
ld32: ERROR   33 : Unresolved text symbol "lsa_get_pipe_fns" -- 1st referenced 
by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "lsa_ds_get_pipe_fns" -- 1st 
referenced by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "samr_get_pipe_fns" -- 1st referenced 
by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "netlog_get_pipe_fns" -- 1st 
referenced by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "wkssvc_get_pipe_fns" -- 1st 
referenced by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "reg_get_pipe_fns" -- 1st referenced 
by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: ERROR   33 : Unresolved text symbol "netdfs_get_pipe_fns" -- 1st 
referenced by rpc_server/srv_pipe.o.
        Use linker option -v to see when and which objects, archives and dsos 
are loaded.
ld32: INFO    152: Output file removed because of error.
collect2: ld returned 2 exit status
make: *** [bin/smbd] Error 1

$
Comment 1 Gerald (Jerry) Carter 2003-12-07 22:54:33 UTC

*** This bug has been marked as a duplicate of 669 ***