Bug 6669 - printer driver short architecture dir (w32x86) is not treated case insensitive
printer driver short architecture dir (w32x86) is not treated case insensitive
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Printing
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
: 7372 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-28 06:54 UTC by Guenther Deschner
Modified: 2013-01-18 15:38 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2009-08-28 06:54:39 UTC
This is a follow up bug to bug #6568.

Printer driver upload fails when w32x86 has not been created in upper-case on the print$ share.

It should not matter in what case this directory has been created.
Comment 1 Karolin Seeger 2010-01-25 08:45:13 UTC
Too late for enhancements for 3.5. Raising version.
Comment 2 Guenther Deschner 2010-04-20 05:57:43 UTC
*** Bug 7372 has been marked as a duplicate of this bug. ***
Comment 3 Guenther Deschner 2010-04-20 05:58:27 UTC
raising priority
Comment 4 Chris Smith 2012-02-10 00:13:51 UTC
FYI, cupsaddsmb, which is bundled with CUPS, requires W32X86 (upper-case) for 32 bit driver installation and x64 (lower-case) for 64 bit driver installation. I noticed this when trying to add 64 bit drivers and my distro created an upper-case X64 directory (adding a symbolic link as lower-case was a usable workaround). And although Windows is case insensitive it does, with NTFS, preserve case and Windows 7, for example, has an upper-case W32X86, and a lower case x64.
Comment 5 Andreas Schneider 2013-01-18 15:38:36 UTC
I've just tested it here with master and it is working correctly again. Closing.