Bug 6568 - Can't upload printer drivers: Couldn't find service prnproc$
Can't upload printer drivers: Couldn't find service prnproc$
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Printing
3.4.0
x86 Windows XP
: P3 major
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-20 05:06 UTC by Marc Muehlfeld
Modified: 2009-08-28 06:55 UTC (History)
0 users

See Also:
gd: review+


Attachments
vm-02.log.tar.gz (245.01 KB, application/x-gzip)
2009-07-20 13:03 UTC, Marc Muehlfeld
no flags Details
smb.conf (4.53 KB, application/octet-stream)
2009-07-20 13:03 UTC, Marc Muehlfeld
no flags Details
printers.conf (4.91 KB, application/octet-stream)
2009-07-20 13:04 UTC, Marc Muehlfeld
no flags Details
patch to avoid reporting of a prnproc$ share. (1.23 KB, patch)
2009-08-04 05:28 UTC, Guenther Deschner
no flags Details
New debug level 10 logfile (396.35 KB, application/x-gzip)
2009-08-05 05:21 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2009-07-20 05:06:05 UTC
Uploading printer drivers on my 3.4.0 PDC fails during the copy process. The logfile says: Couldn't find service prnproc$.
Comment 1 Jeremy Allison 2009-07-20 12:55:48 UTC
Can you attach your smb.conf and a debug level 10 log showing the problem please ?
Thanks,
Jeremy.
Comment 2 Marc Muehlfeld 2009-07-20 13:03:03 UTC
Created attachment 4448 [details]
vm-02.log.tar.gz

Ups. My level-10 log wasn't attached because of the size.
I appended it compressed.
Comment 3 Marc Muehlfeld 2009-07-20 13:03:39 UTC
Created attachment 4449 [details]
smb.conf
Comment 4 Marc Muehlfeld 2009-07-20 13:04:05 UTC
Created attachment 4450 [details]
printers.conf

The included printer part of smb.conf.
Comment 5 Guenther Deschner 2009-08-03 08:43:27 UTC
Also, what exact printer driver is this ?
Comment 6 Marc Muehlfeld 2009-08-03 08:47:03 UTC
This seem to happen with all drivers.

I allready tried:
- HP CP1515 PCL6
- HP CP1515 PS
- HP Universal Printer Driver PCL5
- Sharp MX 2600 PS
- Sharp MX 2600 PCL5e
- Sharp MX 2600 PCL6
Comment 7 Guenther Deschner 2009-08-04 05:28:52 UTC
Created attachment 4508 [details]
patch to avoid reporting of a prnproc$ share.

Could you please try this patch ?
Comment 8 Guenther Deschner 2009-08-04 17:16:47 UTC
Jeremy, for the happiness of the process, please ACK - and I know you love processes :)
Comment 9 Jeremy Allison 2009-08-04 19:08:13 UTC
Good catch, thanks for the fix. Assigning to Karolin so that it can be pushed into 3.4.1.
Jeremy.
Comment 10 Karolin Seeger 2009-08-05 04:48:28 UTC
Patch will be included in 3.4.1.
Closing out bug report.

Thanks!
Comment 11 Marc Muehlfeld 2009-08-05 05:20:10 UTC
After applying the patch, the error message is gone. But uploading drivers still doesn't work.

The logfile now shows:
[2009/08/05 08:37:50,  0] printing/nt_printing.c:1827(move_driver_file_to_download_area)
  move_driver_file_to_download_area: Unable to rename [w32x86/UNIDRV.DLL] to [W32X86/3/UNIDRV.DLL]: NT_STATUS_OBJECT_NAME_NOT_FOUND

I also created a debug level 10 logfile for that. Included is the try of uploading the "HP CP1515 PCL6" driver.

Should I open a new bug for this?
Comment 12 Marc Muehlfeld 2009-08-05 05:21:49 UTC
Created attachment 4517 [details]
New debug level 10 logfile

Compressed level 10 debug log of the renaming error that came up after appling the patch.
Comment 13 Karolin Seeger 2009-08-05 05:23:25 UTC
I think reopening should be fine.
Comment 14 Guenther Deschner 2009-08-07 10:26:31 UTC
Marc, I was finally able to reproduce that. To me this only happend when inside the print$ share on disc the w32x86 directory is in lowercase. Once I uppercase it to be W32X86, I could install e.g. cp1215 ps without problems. Can you try that please as a quick workaround ?
Comment 15 Marc Muehlfeld 2009-08-09 15:11:03 UTC
You are right. If I rename it to W32X86, it works.

But some weeks ago I reinstalled samba completely from scratch (the latest version that time was 3.3.4). There this directory was created in lower case. I don't know if also was before I reinstalled.

Should it allways be in lower case? So wrong created by samba? Or is it a bug in 3.4.0 because it expect it in upper case only?
Comment 16 Guenther Deschner 2009-08-11 11:54:33 UTC
(In reply to comment #15)
> You are right. If I rename it to W32X86, it works.
> 
> But some weeks ago I reinstalled samba completely from scratch (the latest
> version that time was 3.3.4). There this directory was created in lower case. I
> don't know if also was before I reinstalled.
> 
> Should it allways be in lower case? So wrong created by samba? Or is it a bug
> in 3.4.0 because it expect it in upper case only?

IIRC the W32X86 directory is not created by samba at all. Only the numeric version subdirectories are created it seems. In any case, Samba needs to cope with any case here.

> 

Comment 17 Marc Muehlfeld 2009-08-12 03:36:53 UTC
I tried it. You are right. The W32X86 isn't created automatically. Maybe this would be a small feature for the next version :-)
Comment 18 Guenther Deschner 2009-08-28 06:52:06 UTC
Ok, closing out this one.

For the case insensitivity on the short architecture dir (w32x86) I will add a new enhancement bug (as this is apparently not a regression).
Comment 19 Guenther Deschner 2009-08-28 06:55:30 UTC
Marc, I created the followup bug #6669 to handle the case problem of the w32x86 dir.