Bug 7372 - w32x86 for print driver is case sensitve
w32x86 for print driver is case sensitve
Status: RESOLVED DUPLICATE of bug 6669
Product: Samba 3.4
Classification: Unclassified
Component: Printing
3.4.5
x86 FreeBSD
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-19 14:16 UTC by phil
Modified: 2010-04-20 05:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phil 2010-04-19 14:16:40 UTC
samba 3.4.5 built on Freebsd 8.0 out of ports.

During uploading of print drivers, it seems that the w32x86 in the samba drivers directory for print$ is case sensitive. I had originally created this directory in lower case (like I did for 3.0.37), and then I get this error in the log:

[2010/04/18 12:54:39,  0] printing/nt_printing.c:1827(move_driver_file_to_downlo
ad_area)
  move_driver_file_to_download_area: Unable to rename [w32x86/UNIDRV.DLL] to [W3
2X86/3/UNIDRV.DLL]: NT_STATUS_OBJECT_NAME_NOT_FOUND

Changing to upper case resolved this problem.

There also seems to be some permission problems that I am unable to find (even though I set the directory to be 0777, just for grins). Here is the error message:

[2010/04/18 12:54:36,  0] smbd/service.c:1009(make_connection_snum)
  '/usr/local/etc/samba34/drivers' does not exist or permission denied when conn
ecting to [print$] Error was Permission denied

Maybe it is connected to the previous failure above?

-phil
Comment 1 Guenther Deschner 2010-04-20 05:57:43 UTC
Ok, then it is a regression we need to fix. Closing as a duplicate of another bug we already have for this.

*** This bug has been marked as a duplicate of bug 6669 ***