Bug 5539 - rsync -X does not work
rsync -X does not work
Status: CLOSED DUPLICATE of bug 5538
Product: rsync
Classification: Unclassified
Component: core
x64 Linux
: P3 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-06-11 22:22 UTC by Bill C Riemers
Modified: 2008-07-28 20:45 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Bill C Riemers 2008-06-11 22:22:13 UTC
With the git source, the -X flag no-longer works.  I suspect this problem was introduced fixing bug #5526.

For a simple test case try:

sudo mkdir /var2
sudo rsync -aX --link-dest=/var /var/. /var2/.
ls -laZ /var2

You should see that /var2 does not have the correct xattributes.
Comment 1 Bill C Riemers 2008-06-11 22:23:54 UTC
Opps.  Look like I hit submit twice.

*** This bug has been marked as a duplicate of 5538 ***