Bug 5538 - -X with --link-dest/--copy-dest fails to copy xattrs on an unchanged-attr dir
-X with --link-dest/--copy-dest fails to copy xattrs on an unchanged-attr dir
Status: CLOSED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.0.3
x64 Linux
: P3 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
https://bugzilla.samba.org/show_bug.c...
:
: 5539 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 22:07 UTC by Bill C Riemers
Modified: 2008-07-28 20:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill C Riemers 2008-06-11 22:07:25 UTC
With the git source, the -X flag no-longer works.  I suspect this problem was introduced fixing bug #5526.

For a simple test case try:

sudo mkdir /var2
sudo rsync -aX --link-dest=/var /var/. /var2/.
ls -laZ /var2

You should see that /var2 does not have the correct xattributes.
Comment 1 Bill C Riemers 2008-06-11 22:23:54 UTC
*** Bug 5539 has been marked as a duplicate of this bug. ***
Comment 2 Wayne Davison 2008-06-12 10:03:48 UTC
This bug has been around since 3.0.0, so no, it's not recently introduced.  I should have it fixed soon.
Comment 3 Wayne Davison 2008-06-13 01:16:02 UTC
The fix for this was committed to the git repository, and is available in the most recently "nightly" tar file.