Bug 5526 - problems with rsync -X --link-dest
problems with rsync -X --link-dest
Status: CLOSED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.0.3
Other Linux
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 07:47 UTC by Simo Sorce
Modified: 2008-07-28 20:32 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simo Sorce 2008-06-08 07:47:48 UTC
See RH bugzilla, it contains reproducible case:
https://bugzilla.redhat.com/show_bug.cgi?id=450364
Comment 1 Simo Sorce 2008-06-08 07:49:52 UTC
The RH binaries use the ACL patch for backward compatibility with previous version of patched rsync
Comment 2 Wayne Davison 2008-06-08 22:55:01 UTC
This is now fixed in the git repository.

This bug could also affect runs that did not use --link-dest:

If a file was transferred w/o any xattr changes, and a later file needed to update its xattrs to be the same as the earlier file, the receiver and the generator had different ideas about what was still abbreviated (and the receiver died with an error).

Thanks for the helpful test case!
Comment 3 Bill C Riemers 2008-06-10 12:10:30 UTC
I just tried a build from git.  It looks like xattr are not being copied at all now...

# rsync -aXHSA --delete --link-dest=/media/backups/hartnell.local/DellPrecision490/Fedora9/200806101037.dir /dev/shm/lvbackup/src/. /media/backups/hartnell.local/DellPrecision490/Fedora9/200806101248.dir/.
# ls -ladZ /media/backups/hartnell.local/DellPrecision490/Fedora9/200806101037.dir/var
drwxr-xr-x  root root system_u:object_r:var_t:s0       /media/backups/hartnell.local/DellPrecision490/Fedora9/200806101037.dir/var
# ls -ladZ /media/backups/hartnell.local/DellPrecision490/Fedora9/200806101248.dir/var
drwxr-xr-x  root root unconfined_u:object_r:default_t:s0 /media/backups/hartnell.local/DellPrecision490/Fedora9/200806101248.dir/var

Comment 4 Bill C Riemers 2008-06-10 12:15:53 UTC
I would reopen this, but it looks like I don't have sufficient privilege.

For a simple test case:

sudo mkdir /var2
sudo rsync -aX --link-dest=/var /var/. /var2/.
ls -laZ /var2
Comment 5 Wayne Davison 2008-07-28 20:32:27 UTC
(Note that the immediately prior comments about the bug not being fixed were actually a different, old bug that was fixed in bug 5538.)