Bug 526 - smbd, nmbd, etc. coredump
smbd, nmbd, etc. coredump
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
All AIX
: P3 regression
: none
Assigned To: Tim Potter
:
: 191 640 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-27 15:28 UTC by Rick Cochran
Modified: 2005-11-14 09:25 UTC (History)
2 users (show)

See Also:


Attachments
patches to "configure" to get all packages to build static (1.11 KB, text/plain)
2003-09-29 10:55 UTC, Rick Cochran
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Cochran 2003-09-27 15:28:36 UTC
Everything builds fine, but:

irene> sudo samba-3.0.0rc4-gcc/sbin/smbd
Abort (core dumped)

and:

irene> sudo samba-3.0.0rc4-gcc/bin/smbclient 
[2003/09/27 18:26:31, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/common/samba/lib/charset/CP850.so: No such file or directory
[2003/09/27 18:26:31, 0] lib/charcnv.c:init_iconv(133)
  Conversion from UCS-2LE to CP850 not supported
[2003/09/27 18:26:31, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/common/samba/lib/charset/CP850.so: No such file or directory
[2003/09/27 18:26:31, 0] lib/charcnv.c:init_iconv(133)
  Conversion from UTF8 to CP850 not supported
[2003/09/27 18:26:31, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/common/samba/lib/charset/CP850.so: No such file or directory
[2003/09/27 18:26:31, 0] lib/charcnv.c:init_iconv(133)
  Conversion from ASCII to CP850 not supported
[2003/09/27 18:26:31, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/common/samba/lib/charset/CP850.so: No such file or directory
[2003/09/27 18:26:31, 0] lib/charcnv.c:init_iconv(133)
  Conversion from CP850 to UCS-2LE not supported
Segmentation fault (core dumped)
irene> ls -l /usr/common/samba/lib/charset/CP850.so
-rwxr-xr-x   1 root     systems   366553 Sep 27 17:09
/usr/common/samba/lib/charset/CP850.so

Same result with both gcc and IBM cc.

I'm going to try --disable-shared
Comment 1 Rick Cochran 2003-09-27 17:28:48 UTC
Yup.  '--disable-shared' works, but only if I edit 'configure' to build all the
packages 'static'.

So I'd say that building 'shared' is broken on AIX, your most popular platform.
Comment 2 Tim Potter 2003-09-28 17:50:28 UTC
Heh.  Well if you can figure out how to build shared libraries correctly please
let us know.  According to
http://www16.boulder.ibm.com/pseries/en_US/aixprggd/genprogc/create_shared_lib.htm
all you need is -bM:SRE and -bnoentry to build shared libraries.

Can you confirm (do a make distclean and re-run configure with
--disabled-shared) that Samba still tries to build shared library stuff?  If so
it would be great if you could file another bug.
Comment 3 Rick Cochran 2003-09-29 10:55:18 UTC
Created attachment 172 [details]
patches to "configure" to get all packages to build static

I have made it a life goal to not learn how to build shared libraries under
AIX.  I don't think it's a growth industry.

I _always_ 'rm -rf' and start with a fresh untar when re-doing a build.

I'm attaching the diff from configure.	I suppose I could have typed all those
package names on the command line . . .

Obviously, this is not a patch you are going to want to distribute!

Finally, I still get "Error loading module
'/usr/common/samba/lib/charset/ISO8859-1.so': No such file or directory" in my
smb log.  I'm currently ignoring it.
Comment 4 Jim McDonough 2003-12-12 06:00:05 UTC
*** Bug 640 has been marked as a duplicate of this bug. ***
Comment 5 Gerald (Jerry) Carter 2004-03-18 10:04:18 UTC
*** Bug 191 has been marked as a duplicate of this bug. ***
Comment 6 Rick Cochran 2004-04-17 06:42:33 UTC
Samba 3.0.2a builds fine with gcc-3.2.2 under AIX 5.2.

I don't know about others, but this bug is now resolved for me.
Comment 7 Gerald (Jerry) Carter 2004-04-22 19:31:07 UTC
thanks for the update.  Closing.
Comment 8 Gerald (Jerry) Carter 2005-02-07 09:06:16 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:16:28 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 10 Gerald (Jerry) Carter 2005-11-14 09:25:30 UTC
database cleanup