Bug 191 - Dyanmic vfs modules cause smbd to segfault on AIX
Dyanmic vfs modules cause smbd to segfault on AIX
Status: RESOLVED DUPLICATE of bug 526
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
Other other
: P4 normal
: none
Assigned To: Tim Potter
Depends on:
  Show dependency treegraph
Reported: 2003-06-27 07:20 UTC by Stephen Roylance
Modified: 2005-02-07 08:39 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Roylance 2003-06-27 07:20:47 UTC
#0  0xd01e8998 in waitpid ()
#1  0xd01dd720 in system ()
#2  0x1001d0b0 in smb_panic (why=0x10261368 "internal error") at lib/util.c:1453
#3  0x101981bc in fault_report (sig=11) at lib/fault.c:41
#4  0x10198268 in sig_fault (sig=-1) at lib/fault.c:61
#5  <signal handler called>
#6  0xd2ad9f68 in smb_register_vfs ()
#7  0xd2adb258 in init_module () at sophos/vscan-sophos.c:507
#8  0x1004691c in smb_load_module (module_name=0x601d001d <Address 0x601d001d 
out of bounds>) at lib/module.c:54
#9  0x10046c1c in smb_probe_module (subsystem=0xffffffff <Address 0xffffffff 
out of bounds>,
    module=0x20116148 "vscan-sophos") at lib/module.c:99
#10 0x100f9104 in vfs_init_custom (conn=0x20118c28, vfs_object=0x0) at 
#11 0x100f95c0 in smbd_vfs_init (conn=0x20116148) at smbd/vfs.c:316
#12 0x101674c4 in make_connection_snum (snum=0, vuser=0x20118298, password=
{data = 0x20077e18 "", length = 1,
      free = 0x2000e4b4 <__dbargs+1136>}, pdev=0xffffffff <Address 0xffffffff 
out of bounds>, status=0x7fffff)
    at smbd/service.c:580
#13 0x101684c0 in make_connection (service_in=0x2ff22328 "SFA", password={data 
= 0x20077e18 "", length = 1,
      free = 0x2000e4b4 <__dbargs+1136>}, pdev=0xffffffff <Address 0xffffffff 
out of bounds>, vuid=101,
    status=0x2ff22938) at smbd/service.c:857
#14 0x1004adbc in reply_tcon_and_X (conn=0x2ff22438, inbuf=0x200d5768 "", 
outbuf=0x200f5bb8 "", length=88,
    bufsize=131072) at smbd/reply.c:262
#15 0x10048a74 in switch_message (type=117, inbuf=0x200d5768 "", 
outbuf=0x200f5bb8 "", size=8388607, bufsize=8388607)
    at smbd/process.c:758
#16 0x10048ba0 in construct_reply (inbuf=0x200d5768 "", outbuf=0x200f5bb8 "", 
size=88, bufsize=131072)
    at smbd/process.c:788
#17 0x10049058 in process_smb (inbuf=0x20004510 "", outbuf=0x200f5bb8 "") at 
#18 0x10049ecc in smbd_process () at smbd/process.c:1315
#19 0x1000238c in main (argc=536897816, argv=0x2000b3e8) at smbd/server.c:890
#20 0x10000204 in __start ()

the opinion in #samb-technical is that smb_register_vsf is not being correctly 
exported from smbd.  Someone with knowledge of the AIX linker should look at 
Comment 1 Gerald (Jerry) Carter 2004-03-18 10:04:18 UTC

*** This bug has been marked as a duplicate of 526 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 08:39:00 UTC
originally reported against 3.0.0beta1.  CLeaning out 
non-production release versions.