Bug 640 - Samba 3 core dumps on AIX
Samba 3 core dumps on AIX
Status: RESOLVED DUPLICATE of bug 526
Product: Samba 3.0
Classification: Unclassified
Component: File Services
: P3 regression
: none
Assigned To: Jim McDonough
Depends on:
  Show dependency treegraph
Reported: 2003-10-17 07:12 UTC by Stéphane Davy
Modified: 2005-11-14 09:24 UTC (History)
1 user (show)

See Also:

syslog of samba dump (5.26 KB, text/plain)
2003-12-03 01:58 UTC, Adrian van Bloois
no flags Details
syslog nmbd dump (10.81 KB, text/plain)
2003-12-03 02:02 UTC, Adrian van Bloois
no flags Details
dbx output of samba dump (2.54 KB, text/plain)
2003-12-11 05:28 UTC, Adrian van Bloois
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Davy 2003-10-17 07:12:13 UTC
I've tried to install Samba 3.0.0 on AIX 5.2. I have previously made a
successful install of samba 3 rc1 with ads support. With the 3.0.0 one,
everything is fine during the build and install process. But when I try to use
one or another of the samab binaries, I always have a core dump.
So, I have reduced all the compil options only to --prefix= and I have the same
I've tried the 3.0.1pre1, and it works. But I've copied my final directory to
another AIX 5.2 partition, I still have some core dumps.
I've tried the stable samba release on AIX 4.3.3... and it core dumps also.
Comment 1 Gerald (Jerry) Carter 2003-11-04 20:12:40 UTC
Jim,  here's another one (AIX).
Comment 2 Jim McDonough 2003-11-05 05:28:39 UTC
Stephane, can you please include some more information here, like a backtrace,
and perhaps attach a log.  Does it coredump at startup, or only when the server
is contacted.  Which binaries coredump?  All of them, or just certain ones?
Comment 3 Stéphane Davy 2003-11-19 07:26:19 UTC
(sorry for the delay, I was on holidays)
Unfortunately, I don't have some much details to give. I can say that most of
the binaries core dump: testparm, smbclient, smbd,... NOT nmbd but don't go in
background with -D switch, NOT winbindd. smbd doesn't core dump with -V switch.
Everything have been compiled with the IBM C compiler v5, and the config is a
vanillia one (just --prefix)
The only messages I have is... Segmentation fault(coredump). I don't have a
debugging tool related to these kind of binaries, but I can send you the core
file. I'll make some new test with PRE3 version
Comment 4 Adrian van Bloois 2003-12-02 02:31:29 UTC
We have the same problem, both on AIX 4.3.2 and AIX 5.2.
Comment 5 Jim McDonough 2003-12-02 07:22:28 UTC
Adrian, do you have any more info, like a backtrace?  I'm having a hard time
getting access to an AIX box, so any more debug info that you can give would be
a great help.  debug from any program that cores would be a good start, plus any
core info, like a backtrace.
Comment 6 Adrian van Bloois 2003-12-03 01:58:37 UTC
Created attachment 296 [details]
syslog of samba dump
Comment 7 Adrian van Bloois 2003-12-03 02:02:38 UTC
Created attachment 297 [details]
syslog nmbd dump
Comment 8 Adrian van Bloois 2003-12-03 02:06:21 UTC
Please find attached some syslog information:
attachments #296 and #297 (smbd & nmbd dump info)
Hope this information helps to solve the problem.
Comment 9 Jim McDonough 2003-12-03 08:02:45 UTC
Adrian, is it leaving corefiles anywhere?  I'd like to see a backtrace if at all
possible.  It's possible that this is related to the messages about charset
modules not loading, but I'd like to verify it.  Thanks.

If you do have corefiles, try "dbx smbd core" (just to be safe, use the full
path to smbd) then run "where", and cut/paste the output here.
Comment 10 Adrian van Bloois 2003-12-11 05:28:33 UTC
Created attachment 319 [details]
dbx output of samba dump
Comment 11 Jim McDonough 2003-12-12 06:00:01 UTC
Combining with 526...same problem, iconv on AIX module loading issue...

*** This bug has been marked as a duplicate of 526 ***
Comment 12 Stéphane Davy 2003-12-12 07:49:42 UTC
It works fine after disabling shared et modifying configure according to what
has been described in bug #256
Comment 13 Gerald (Jerry) Carter 2005-11-14 09:24:43 UTC
database cleanup