Bug 3374 - source/nsswitch/wb_common.c won't build on Tru64 UNIX
source/nsswitch/wb_common.c won't build on Tru64 UNIX
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.21a
Alpha OSF/1
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 3372 3403 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 11:32 UTC by The Written Word
Modified: 2006-01-13 09:49 UTC (History)
3 users (show)

See Also:


Attachments
Proposed patch (788 bytes, patch)
2006-01-04 11:33 UTC, The Written Word
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description The Written Word 2006-01-04 11:32:49 UTC
Tru64 UNIX 4.0D and 5.1 don't define socklen_t. Therefore source/nsswitch/wb_common.c won't build because it assumes socklen_t exists.
Comment 1 The Written Word 2006-01-04 11:33:24 UTC
Created attachment 1642 [details]
Proposed patch
Comment 2 Björn Jacke 2006-01-07 14:04:42 UTC
*** Bug 3372 has been marked as a duplicate of this bug. ***
Comment 3 Volker Lendecke 2006-01-08 08:32:39 UTC
Applied with r12771, thanks.

Volker
Comment 4 Björn Jacke 2006-01-13 09:49:52 UTC
*** Bug 3403 has been marked as a duplicate of this bug. ***