Bug 3403 - In this declaration, "socklen_t" must specify a type. (badparsedecl)
In this declaration, "socklen_t" must specify a type. (badparsedecl)
Status: RESOLVED DUPLICATE of bug 3374
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
Alpha Other
: P3 major
: none
Assigned To: Tim Potter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-01-13 09:34 UTC by damien mcgeoghegan
Modified: 2006-01-13 09:49 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description damien mcgeoghegan 2006-01-13 09:34:25 UTC
My environment is TRU64 version 5.1
I'm getting the following error during the make stage

Compiling nsswitch/wb_client.c
Compiling nsswitch/wb_common.c
cc: Error: nsswitch/wb_common.c, line 238: In this declaration, "socklen_t" must specify a type. (badparsedecl)
                socklen_t errnosize;
cc: Error: nsswitch/wb_common.c, line 253: In this statement, "errnosize" is not declared. (undeclared)
                                        errnosize = sizeof(connect_errno);
*** Exit 1
Comment 1 Björn Jacke 2006-01-13 09:49:52 UTC

*** This bug has been marked as a duplicate of 3374 ***