Bug 3372 - Samba 3.0.21a compilation failure under Tru64 Unix 5.1
Samba 3.0.21a compilation failure under Tru64 Unix 5.1
Status: RESOLVED DUPLICATE of bug 3374
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.21a
Alpha OSF/1
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 10:03 UTC by Scott McAskill
Modified: 2006-01-07 14:04 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott McAskill 2006-01-04 10:03:52 UTC
Compilation of 3.0.21a (and 3.0.21) under Tru64 Unix 5.1 using the native compiler fails asa follows:

.
.
.
Compiling lib/fsusage.c
Compiling lib/ms_fnmatch.c
Compiling lib/select.c
Compiling lib/messages.c
Compiling lib/tallocmsg.c
Compiling lib/dmallocmsg.c
Compiling libsmb/smb_signing.c
Compiling lib/md5.c
Compiling lib/hmacmd5.c
Compiling lib/arc4.c
Compiling lib/iconv.c
Compiling nsswitch/wb_client.c
Compiling nsswitch/wb_common.c
cc: Error: nsswitch/wb_common.c, line 238: In this declaration, "socklen_t" must specify a type. (badparsedecl)
                socklen_t errnosize;
----------------^
cc: Error: nsswitch/wb_common.c, line 253: In this statement, "errnosize" is not declared. (undeclared)
                                        errnosize = sizeof(connect_errno);
----------------------------------------^
*** Exit 1
Stop.
#
Comment 1 Björn Jacke 2006-01-07 14:04:42 UTC
here you find a the needed patch - can someone of the team please check this in?

*** This bug has been marked as a duplicate of 3374 ***