Bug 1715 - INTERNAL ERROR: Signal 11 in pid (ldapsam_compat maybe?)
INTERNAL ERROR: Signal 11 in pid (ldapsam_compat maybe?)
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.6
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 1749 1781 1785 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 06:19 UTC by Noël Köthe
Modified: 2005-08-24 10:25 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Noël Köthe 2004-09-03 06:19:13 UTC
Hello,

I'm runing a samba2.2.x + ldap enviroment on a SuSE SLES 8 without a problem
right now.
Now I want to integrate a samba3 machine to start the migration from samba 2 to
samba 3.
Documentations says to use ldapsam_compat for this setup as passdb backend.
But I tried to get it runing produces always: INTERNAL ERROR:

This is the error:

Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/fault.c:fault_report(36)
Sep  3 15:05:04 hydra01 smbd[12737]:  
===============================================================
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/fault.c:fault_report(37)
Sep  3 15:05:04 hydra01 smbd[12737]:   INTERNAL ERROR: Signal 11 in pid 12737
(3.0.6)
Sep  3 15:05:04 hydra01 smbd[12737]:   Please read the appendix Bugs of the
Samba HOWTO collection
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/fault.c:fault_report(39)
Sep  3 15:05:04 hydra01 smbd[12737]:  
===============================================================
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/util.c:smb_panic2(1375)
Sep  3 15:05:04 hydra01 smbd[12737]:   smb_panic(): calling panic action
[/usr/share/samba/panic-action 12737]
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/util.c:smb_panic2(1383)
Sep  3 15:05:04 hydra01 smbd[12737]:   smb_panic(): action returned status 127
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/util.c:smb_panic2(1385)
Sep  3 15:05:04 hydra01 smbd[12737]:   PANIC: internal error
Sep  3 15:05:04 hydra01 smbd[12737]: [2004/09/03 15:05:04, 0]
lib/util.c:smb_panic2(1393)
Sep  3 15:05:04 hydra01 smbd[12737]:   BACKTRACE: 26 stack frames:
Sep  3 15:05:04 hydra01 smbd[12737]:    #0 /usr/sbin/smbd(smb_panic2+0x176)
[0x8197d06]
Sep  3 15:05:04 hydra01 smbd[12737]:    #1 /usr/sbin/smbd(smb_panic+0x13)
[0x8197b8b]
Sep  3 15:05:04 hydra01 smbd[12737]:    #2 /usr/sbin/smbd [0x81881f3]
Sep  3 15:05:04 hydra01 smbd[12737]:    #3 /usr/sbin/smbd [0x8188255]
Sep  3 15:05:04 hydra01 smbd[12737]:    #4 /lib/libc.so.6 [0x401756b8]
Sep  3 15:05:04 hydra01 smbd[12737]:    #5 /usr/sbin/smbd [0x8176647]
Sep  3 15:05:04 hydra01 smbd[12737]:    #6 /usr/sbin/smbd [0x81766a4]
Sep  3 15:05:04 hydra01 smbd[12737]:    #7 /usr/sbin/smbd [0x816f16d]
Sep  3 15:05:04 hydra01 smbd[12737]:    #8 /usr/sbin/smbd(pdb_getsampwnam+0x29)
[0x81709b1]
Sep  3 15:05:04 hydra01 smbd[12737]:    #9 /usr/sbin/smbd [0x81c72ae]
Sep  3 15:05:04 hydra01 smbd[12737]:    #10 /usr/sbin/smbd [0x81c783d]
Sep  3 15:05:04 hydra01 smbd[12737]:    #11 /usr/sbin/smbd [0x81c5608]
Sep  3 15:05:04 hydra01 smbd[12737]:    #12 /usr/sbin/smbd [0x81cce04]
Sep  3 15:05:04 hydra01 smbd[12737]:    #13 /usr/sbin/smbd [0x80eccc4]
Sep  3 15:05:04 hydra01 smbd[12737]:    #14 /usr/sbin/smbd(ntlmssp_update+0x1e9)
[0x80ec0cd]
Sep  3 15:05:04 hydra01 smbd[12737]:    #15
/usr/sbin/smbd(auth_ntlmssp_update+0x28) [0x81cd0e0]
Sep  3 15:05:05 hydra01 smbd[12737]:    #16 /usr/sbin/smbd [0x80a46f4]
Sep  3 15:05:05 hydra01 smbd[12737]:    #17 /usr/sbin/smbd [0x80a49aa]
Sep  3 15:05:05 hydra01 smbd[12737]:    #18
/usr/sbin/smbd(reply_sesssetup_and_X+0x15a) [0x80a4bca]
Sep  3 15:05:05 hydra01 smbd[12737]:    #19 /usr/sbin/smbd [0x80c24cb]
Sep  3 15:05:05 hydra01 smbd[12737]:    #20 /usr/sbin/smbd [0x80c2563]
Sep  3 15:05:05 hydra01 smbd[12737]:    #21 /usr/sbin/smbd(process_smb+0x187)
[0x80c2803]
Sep  3 15:05:05 hydra01 smbd[12737]:    #22 /usr/sbin/smbd(smbd_process+0x14f)
[0x80c31df]
Sep  3 15:05:05 hydra01 smbd[12737]:    #23 /usr/sbin/smbd(main+0x6cb) [0x81f7bdf]
Sep  3 15:05:05 hydra01 smbd[12737]:    #24
/lib/libc.so.6(__libc_start_main+0xbb) [0x4016514f]
Sep  3 15:05:05 hydra01 smbd[12737]:    #25 /usr/sbin/smbd(ldap_msgfree+0x71)
[0x8078c61]
Sep  3 15:05:05 hydra01 smbd[12737]:

I tested it with the following packages (all 3.0.6): SuSE SLES 8 i386 from
ftp.sernet.de; Debian woody backport from de.samba.org, Debian sarge package
included in the Debian distribution.

This is the smb.conf:

# Global parameters
[global]
        unix charset = ISO8859-15
        workgroup = SOMETHING
        server string = Samba Fileserver
        interfaces = lo, eth0
        bind interfaces only = Yes
        obey pam restrictions = Yes
        passdb backend = ldapsam_compat:ldap://ha01
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
        log level = 5
        syslog = 3
        syslog only = Yes
        log file = /var/log/samba/log.%m
        max log size = 1000
        load printers = No
        dns proxy = No
        wins server = 10.41.1.50
        ldap admin dn = cn=cyrus,ou=aaa,o=bbb,c=de
        ldap suffix = ou=aaa,o=bbb,c=de
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        idmap backend = ldap:ldap://localhost
        invalid users = root

[homes]
        comment = Home Directories
        create mask = 0700
        directory mask = 0700
        browseable = No

the end of smbclient -d99 -L localhost on a 3.0.6 machine (Debian):
...
Got challenge flags:
Got NTLMSSP neg_flags=0x608b0215
  NTLMSSP_NEGOTIATE_UNICODE
  NTLMSSP_REQUEST_TARGET
  NTLMSSP_NEGOTIATE_SIGN
  NTLMSSP_NEGOTIATE_NTLM
  NTLMSSP_NEGOTIATE_NTLM2
  NTLMSSP_CHAL_TARGET_INFO
  NTLMSSP_NEGOTIATE_128
  NTLMSSP_NEGOTIATE_KEY_EXCH
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60080215
  NTLMSSP_NEGOTIATE_UNICODE
  NTLMSSP_REQUEST_TARGET
  NTLMSSP_NEGOTIATE_SIGN
  NTLMSSP_NEGOTIATE_NTLM
  NTLMSSP_NEGOTIATE_NTLM2
  NTLMSSP_NEGOTIATE_128
  NTLMSSP_NEGOTIATE_KEY_EXCH
NTLMSSP challenge set by NTLM2
challenge is:
[000] 43 C1 59 10 70 DC 0D C2                           C.Y.p...
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60080215
  NTLMSSP_NEGOTIATE_UNICODE
  NTLMSSP_REQUEST_TARGET
  NTLMSSP_NEGOTIATE_SIGN
  NTLMSSP_NEGOTIATE_NTLM
  NTLMSSP_NEGOTIATE_NTLM2
  NTLMSSP_NEGOTIATE_128
  NTLMSSP_NEGOTIATE_KEY_EXCH
write_socket(4,254)
write_socket(4,254) wrote 254
read_socket_with_timeout: timeout read. EOF from client.
receive_smb_raw: length < 0!
client_receive_smb failed
size=0
smb_com=0x0
smb_rcls=0
smb_reh=0
smb_err=0
smb_flg=0
smb_flg2=0
smb_tid=0
smb_pid=0
smb_uid=0
smb_mid=0
smt_wct=0
smb_bcc=0
SPNEGO login failed: Undetermined error
lang_tdb_init: /usr/share/samba/de_DE.UTF-8.msg: Datei oder Verzeichnis nicht
gefunden
session setup failed: Call returned zero bytes (EOF)

If you need more infos/details please tell me.

Thanks alot.
Comment 1 Dan Young 2004-09-08 10:59:31 UTC
Ditto Noèl's comments. I'm using WBEL 3.0 using the 3.0.6-2.3E SRPM rebuilt from
RHEL 3AS. We're using the ldap_compat passdb. Here's the smbd.log output when
doing a "smbclient -U ldapuser -L localhost" login.

[2004/09/08 09:45:55, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/09/08 09:45:55, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 23624 (3.0.6-2.3E)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/09/08 09:45:55, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/09/08 09:45:55, 0] lib/util.c:smb_panic2(1407)
  PANIC: internal error
[2004/09/08 09:45:55, 0] lib/util.c:smb_panic2(1415)
  BACKTRACE: 25 stack frames:
   #0 smbd(smb_panic2+0x14f) [0x801b5f0f]
   #1 smbd(smb_panic+0x27) [0x801b5db7]
   #2 smbd [0x801a1178]
   #3 /lib/tls/libc.so.6 [0xb73a9de8]
   #4 smbd [0x8018bf58]
   #5 smbd [0x8018c008]
   #6 smbd [0x80182628]
   #7 smbd(pdb_getsampwnam+0x35) [0x80184745]
   #8 smbd [0x801f3ebe]
   #9 smbd [0x801f456e]
   #10 smbd [0x801f1832]
   #11 smbd [0x801fb7e1]
   #12 smbd [0x800d0c88]
   #13 smbd(ntlmssp_update+0x1d3) [0x800d0113]
   #14 smbd(auth_ntlmssp_update+0x4b) [0x801fbb4b]
   #15 smbd [0x8007166e]
   #16 smbd [0x800719a4]
   #17 smbd(reply_sesssetup_and_X+0x100c) [0x80072b5c]
   #18 smbd [0x80098e63]
   #19 smbd [0x80099093]
   #20 smbd(process_smb+0xa6) [0x800992e6]
   #21 smbd(smbd_process+0x192) [0x8009a102]
   #22 smbd(main+0x51f) [0x80234faf]
   #23 /lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7397768]
   #24 smbd [0x80036c72]
Comment 2 Volker Lendecke 2004-09-08 11:32:47 UTC
Please check again now with svn revision 2258. Noel, even if this works,
ldapsam_compat is not really an option, this is waay too limited... ;-)

Closing this bug, please reopen if there is anything left in ldapsam_compat.

Thanks,

Volker
Comment 3 Jacco Ligthart 2004-09-08 15:08:04 UTC
I just wanted to share that this patch works for me.
Thanks Volker for the quick fix.

Jacco
Comment 4 Volker Lendecke 2004-09-11 07:46:12 UTC
*** Bug 1749 has been marked as a duplicate of this bug. ***
Comment 5 Volker Lendecke 2004-09-16 07:50:34 UTC
*** Bug 1781 has been marked as a duplicate of this bug. ***
Comment 6 Jason Lander 2004-09-17 06:31:16 UTC
*** Bug 1785 has been marked as a duplicate of this bug. ***
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:25:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.