Bug 1781 - ldapsam_compat broken with samba 3.0.6 and above
ldapsam_compat broken with samba 3.0.6 and above
Status: RESOLVED DUPLICATE of bug 1715
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.6
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 06:11 UTC by Ivano Cristofolini
Modified: 2004-09-16 07:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivano Cristofolini 2004-09-16 06:11:04 UTC
Steps to reproduce:

get samba 3.0.6 or 3.0.7

./configure --with-ldapsam
make
make install

have in smb.conf:
...
passdb backend = ldapsam_compat:ldap://127.0.0.1/
...

# smbpasswd <options> <enter> <enter>
  expected result --> work nicely 
  actual result --> Segmentation Fault

# smbd -D
$ smbclient -L localhost
   expected result --> work nicely
   actual result --> in log.smbd

[2004/09/16 14:57:55, 0] smbd/server.c:main(760)
  smbd version 3.0.6 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2004/09/16 14:58:01, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/09/16 14:58:01, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 19764 (3.0.6)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/09/16 14:58:01, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/09/16 14:58:01, 0] lib/util.c:smb_panic2(1385)
  PANIC: internal error
[2004/09/16 14:58:01, 0] lib/util.c:smb_panic2(1393)
  BACKTRACE: 26 stack frames:
   #0 ./smbd(smb_panic2+0x18c) [0x8196e65]
   #1 ./smbd(smb_panic+0x10) [0x8196cd7]
   #2 ./smbd [0x81873ca]
   #3 ./smbd [0x818741f]
   #4 /lib/tls/libc.so.6 [0xa6ff38]
   #5 ./smbd [0x8175942]
   #6 ./smbd [0x817599d]
   #7 ./smbd [0x816e6b0]
   #8 ./smbd(pdb_getsampwnam+0x29) [0x816fe08]
   #9 ./smbd [0x81c7965]
   #10 ./smbd [0x81c7ece]
   #11 ./smbd [0x81c5d85]
   #12 ./smbd [0x81cd1ef]
   #13 ./smbd [0x80eab46]
   #14 ./smbd(ntlmssp_update+0x18e) [0x80e9fff]
   #15 ./smbd(auth_ntlmssp_update+0x25) [0x81cd4b8]
   #16 ./smbd [0x80a40f3]
   #17 ./smbd [0x80a436d]
   #18 ./smbd(reply_sesssetup_and_X+0x15d) [0x80a45a6]
   #19 ./smbd [0x80c22a9]
   #20 ./smbd [0x80c2333]
   #21 ./smbd(process_smb+0x1b7) [0x80c262f]
   #22 ./smbd(smbd_process+0x157) [0x80c3112]
   #23 ./smbd(main+0x715) [0x81f60cd]
   #24 /lib/tls/libc.so.6(__libc_start_main+0xe4) [0xa5dad4]
   #25 ./smbd [0x8078431]

NOTES:
- tried on Fedora Core 2 and Red Hat 8.0, same result;
- my openLDAP config is correct because passdb backend =
ldapsam:ldap://127.0.0.1 works correctly;
- Samba versions 3.0.5 and earlier work too.

Thanks,
Comment 1 Volker Lendecke 2004-09-16 07:50:30 UTC

*** This bug has been marked as a duplicate of 1715 ***