Bug 1785 - Missing entry in LDAP attribute map for ldapsam_compat -> SEGV
Missing entry in LDAP attribute map for ldapsam_compat -> SEGV
Status: RESOLVED DUPLICATE of bug 1715
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.7
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 17:34 UTC by Jason Lander
Modified: 2004-09-17 06:31 UTC (History)
0 users

See Also:


Attachments
Adds missing attribute to attribute map (438 bytes, patch)
2004-09-16 17:37 UTC, Jason Lander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lander 2004-09-16 17:34:24 UTC
SMBD seg-faults when acting as a (backup) domain controller
using the ldapsam_compat passdb backend.

Fault is traceable to the use of the LDAP_ATTR_MOD_TIMESTAMP 
attribute, which is missing from attrib_map_v22
Comment 1 Jason Lander 2004-09-16 17:37:08 UTC
Created attachment 665 [details]
Adds missing attribute to attribute map

After this change was made, it is possible to use
smbclient to communicate with an smbd without crashing
the smbd.
Comment 2 Jason Lander 2004-09-17 06:31:11 UTC

*** This bug has been marked as a duplicate of 1715 ***