Bug 12105 - smbclient connection to not reachable IP eats 100% CPU
smbclient connection to not reachable IP eats 100% CPU
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
unspecified
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 12112 12185 12201 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-03 13:12 UTC by Ralph Böhme
Modified: 2016-09-02 15:14 UTC (History)
5 users (show)

See Also:


Attachments
Patch for 4.3, 4.4 and 4.5 cherry-picked from master (2.06 KB, patch)
2016-08-04 13:44 UTC, Ralph Böhme
metze: review+
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Böhme 2016-08-03 13:12:44 UTC
05d4dbda8357712cb81008e0d611fdb0e7239587 introduced a regression that can result in a busy loop around async_connect_send() in open_socket_out_send() when the IP is not immediately reachable.

Have patch, need bugnumber.
Comment 1 Ralph Böhme 2016-08-04 13:44:40 UTC
Created attachment 12311 [details]
Patch for 4.3, 4.4 and 4.5 cherry-picked from master
Comment 2 Ralph Böhme 2016-08-04 16:00:23 UTC
*** Bug 12112 has been marked as a duplicate of this bug. ***
Comment 3 seb128 2016-08-04 16:02:35 UTC
sorry for the duplicate, I looked at open bugs yesterday and got busy and reported open one to today and you opened yours in between, nice to see a patch included ;-)
Comment 4 Karolin Seeger 2016-08-05 07:47:57 UTC
Pushed to autobuild-v4-[5|4|3]-test.
Comment 5 Ralph Böhme 2016-08-09 05:27:10 UTC
Hm, it looks like the fix is in 4.3 and 4.3, but not 4.5? Karolin, can you please check this? Thanks!
Comment 6 Karolin Seeger 2016-08-09 07:45:08 UTC
(In reply to Ralph Böhme from comment #5)
autobuild-v4-5-test failed several times...
Waiting for autobuild fixes (Backports from master).
Comment 7 Karolin Seeger 2016-08-11 08:37:29 UTC
(In reply to Karolin Seeger from comment #6)
Pushed to all branches.
Closing out bug report.

Thanks!
Comment 8 Christian Ambach 2016-08-28 10:29:19 UTC
*** Bug 12185 has been marked as a duplicate of this bug. ***
Comment 9 Christian Ambach 2016-09-02 15:14:47 UTC
*** Bug 12201 has been marked as a duplicate of this bug. ***