Bug 12185 - libsmbclient and smbtree gets stuck and load cpu a lot
libsmbclient and smbtree gets stuck and load cpu a lot
Status: RESOLVED DUPLICATE of bug 12105
Product: Samba 4.1 and newer
Classification: Unclassified
x64 Linux
: P5 major
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-08-27 12:27 UTC by Alex
Modified: 2016-08-28 10:29 UTC (History)
1 user (show)

See Also:

gdb smbtree backtrace. (1.23 KB, text/plain)
2016-08-27 12:27 UTC, Alex
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2016-08-27 12:27:30 UTC
Created attachment 12412 [details]
gdb smbtree backtrace.

When I called smbtree on my local network, I've found that after writing few servers of WORKGROUP on stdout it gets stuck and load cpu a lot.

When I applied gdb, I've found out that it's do_fnctl stuck in libc, but I didn't find where do you call it in your code, backtrace is attached.

The same is happens if I trying to connect to some peer(probably, which stuck) through using libsmbclient. Please, help me understand where problem is and/or fix it :)
Comment 1 Christian Ambach 2016-08-28 10:29:19 UTC
Looks a duplicate of Bug 12105.

*** This bug has been marked as a duplicate of bug 12105 ***