Bug 9854 - 3.6.14 - Recurring segfaults in winbind
3.6.14 - Recurring segfaults in winbind
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Winbind
3.6.14
x64 Linux
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9847 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-05 20:47 UTC by Marc Muehlfeld
Modified: 2013-05-12 09:50 UTC (History)
2 users (show)

See Also:


Attachments
Find attached an archive with my log.wb-{servername}, a coredump file, and the global part of my smb.conf. (234.80 KB, application/x-bzip2)
2013-05-05 20:47 UTC, Marc Muehlfeld
no flags Details
log.wb-GENOME (241.76 KB, text/plain)
2013-05-06 18:56 UTC, Marc Muehlfeld
no flags Details
gdb bt full output (13.81 KB, text/plain)
2013-05-06 18:59 UTC, Marc Muehlfeld
no flags Details
Patch (888 bytes, patch)
2013-05-06 19:48 UTC, Volker Lendecke
no flags Details
Patch for master (1.41 KB, patch)
2013-05-07 10:40 UTC, Volker Lendecke
asn: review+
Details
Patch for 3.6 (1.65 KB, patch)
2013-05-07 13:41 UTC, Volker Lendecke
asn: review+
Details
Patch for 4.0 (1.65 KB, patch)
2013-05-07 13:42 UTC, Volker Lendecke
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2013-05-05 20:47:30 UTC
Created attachment 8850 [details]
Find attached an archive with my log.wb-{servername}, a coredump file, and the global part of my smb.conf.

After I updated one of our file-/printserver to 3.6.14, winbind crashed 4 times in 2 minutes. After restarting, I had several winbind segfaults and core dumps, too in a short time. So I downgraded back to 3.6.13 and everything was fine again.



[2013/05/05 21:39:48.537056,  0] lib/fault.c:51(fault_report)
  ===============================================================
[2013/05/05 21:39:48.537099,  0] lib/util.c:1117(smb_panic)
  PANIC (pid 731): internal error
[2013/05/05 21:39:48.540717,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 19 stack frames:
   #0 /usr/sbin/winbindd(log_stack_trace+0x1c) [0x7f4440e2fb2c]
   #1 /usr/sbin/winbindd(smb_panic+0x55) [0x7f4440e2fc2e]
   #2 /usr/sbin/winbindd(+0x18bb97) [0x7f4440e21b97]
   #3 /lib64/libc.so.6(+0x3491c32920) [0x7f443e6b4920]
   #4 /usr/sbin/winbindd(+0xd484a) [0x7f4440d6a84a]
   #5 /usr/sbin/winbindd(+0xdc698) [0x7f4440d72698]
   #6 /usr/sbin/winbindd(_wbint_LookupRids+0x78) [0x7f4440d8d53c]
   #7 /usr/sbin/winbindd(+0x100462) [0x7f4440d96462]
   #8 /usr/sbin/winbindd(winbindd_dual_ndrcmd+0xfb) [0x7f4440d8c503]
   #9 /usr/sbin/winbindd(+0xf5533) [0x7f4440d8b533]
   #10 /usr/sbin/winbindd(+0xf57ab) [0x7f4440d8b7ab]
   #11 /usr/sbin/winbindd(+0x1aa539) [0x7f4440e40539]
   #12 /usr/sbin/winbindd(tevent_common_loop_immediate+0x128) [0x7f4440e3f10c]
   #13 /usr/sbin/winbindd(run_events_poll+0x3c) [0x7f4440e3d57a]
   #14 /usr/sbin/winbindd(+0x1a7c99) [0x7f4440e3dc99]
   #15 /usr/sbin/winbindd(_tevent_loop_once+0x82) [0x7f4440e3e048]
   #16 /usr/sbin/winbindd(main+0xb84) [0x7f4440d668db]
   #17 /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f443e6a0cdd]
   #18 /usr/sbin/winbindd(+0xcdea9) [0x7f4440d63ea9]
[2013/05/05 21:39:48.541123,  0] lib/util.c:1122(smb_panic)
  smb_panic(): calling panic action [/usr/local/bin/panic-action 731]
[2013/05/05 21:39:48.548982,  0] lib/util.c:1130(smb_panic)
  smb_panic(): action returned status 0
[2013/05/05 21:39:48.549065,  0] lib/fault.c:372(dump_core)
  dumping core in /var/log/samba/cores/winbindd


The libnss_winbind.so file was copied to /lib and ldconfig executed, like after every update.


This server is member in a Samba 4.0.5 AD.
Comment 1 Volker Lendecke 2013-05-06 07:46:30 UTC
Can you get a debug level 10 log of this and install debug symbols, so that the backtrace contains line numbers?

Thanks
Comment 2 Volker Lendecke 2013-05-06 12:42:50 UTC
In your smb.conf you have some panic action set. Can you do a "bt full" from that panic action script, or do a "sleep 9999" there, attach with gdb. The corefile is only useful on a system that matches yours 100%.

Volker
Comment 3 Marc Muehlfeld 2013-05-06 18:56:10 UTC
Created attachment 8855 [details]
log.wb-GENOME
Comment 4 Marc Muehlfeld 2013-05-06 18:59:39 UTC
Created attachment 8856 [details]
gdb bt full output
Comment 5 Volker Lendecke 2013-05-06 19:48:54 UTC
Created attachment 8857 [details]
Patch

Can you try the attached patch?
Comment 6 Marc Muehlfeld 2013-05-06 20:59:14 UTC
Compiled with patch and running now since almost 1h without any segfaults. Looks good at the moment. But I'll give tomorrow a final feedback.
Comment 7 Marc Muehlfeld 2013-05-07 06:56:04 UTC
No more segfaults/panics appeared with your patch. Thanks.
Comment 8 Volker Lendecke 2013-05-07 10:40:58 UTC
Created attachment 8860 [details]
Patch for master
Comment 9 Michael Adam 2013-05-07 11:02:17 UTC
(In reply to comment #8)
> Created attachment 8860 [details]
> Patch for master

Looks good to me.
I just pushed it to autobuild.
Comment 10 Volker Lendecke 2013-05-07 13:41:42 UTC
Created attachment 8867 [details]
Patch for 3.6
Comment 11 Volker Lendecke 2013-05-07 13:42:11 UTC
Created attachment 8868 [details]
Patch for 4.0
Comment 12 Volker Lendecke 2013-05-07 14:03:19 UTC
This is a defect that I would call a regression from 3.6.13 to 3.6.14.
Comment 13 Karolin Seeger 2013-05-08 08:55:35 UTC
Pushed to v3-6-test and autobuild-v4-0-test.
Comment 14 Karolin Seeger 2013-05-08 08:56:14 UTC
Samba 3.6.15 will be shipped today to address this defect.
Comment 15 Karolin Seeger 2013-05-08 19:16:01 UTC
Pushed to v4-0-test.
Comment 16 Karolin Seeger 2013-05-08 19:16:40 UTC
Samba 3.6.15 is out including the fix.
Closing out bug report.

Thanks a lot!
Comment 17 Volker Lendecke 2013-05-12 09:50:56 UTC
*** Bug 9847 has been marked as a duplicate of this bug. ***