Bug 9799 - Managing DNS entries with MMC shows random data
Managing DNS entries with MMC shows random data
Status: RESOLVED DUPLICATE of bug 9791
Product: Samba 4.0
Classification: Unclassified
Component: Tools
4.0.3
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-16 14:05 UTC by doofdilla
Modified: 2013-04-17 13:07 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot 1 (135.98 KB, image/jpeg)
2013-04-16 14:07 UTC, doofdilla
no flags Details
Screenshot 2 (137.44 KB, image/jpeg)
2013-04-16 14:07 UTC, doofdilla
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description doofdilla 2013-04-16 14:05:07 UTC
This is a mirror of the bug outlined here:

https://bugzilla.samba.org/show_bug.cgi?id=9791

I thought it belongs here under "Tools" rather then "other".

Base system: Ubuntu 12.04.2
Samba: latest git version

Reproduce:
Manage samba's DNS entries from a Windows 7 MMC:

Go to reverse zone: A few random containers appear (last part of listed reverse
IP addresses). Pressing F5 changes them to other random values (sometimes a few
reloads are required to trigger this behaviour).

Two screenshots showing this are attached.

Something similar happens in the forward zone: some of the a records are also
displayed as containers, however F5 does not seem to randomize this output
(this can also be seen in the screenshot - but it's not marked)
Comment 1 doofdilla 2013-04-16 14:05:27 UTC
We have the exact same problem as outlined above.

System: Ubuntu 12.04
Samba Version 4.0.3 and 4.0.5
Bind Version 9.8.1-P1 (package) and 9.8.4-P2 (self compiled)

And all combinations of the the above versions

Windows 7 DNS MMC Version: 6.1.7601.17514

Additional Note: It also happened after we migrated to the samba internal dns
Comment 2 doofdilla 2013-04-16 14:07:17 UTC
Created attachment 8775 [details]
Screenshot 1
Comment 3 doofdilla 2013-04-16 14:07:56 UTC
Created attachment 8776 [details]
Screenshot 2
Comment 4 Björn Jacke 2013-04-17 13:07:30 UTC
please don't duplicate bug reports intentionally. the component of the first bug report is fine and doesn't really matter.

*** This bug has been marked as a duplicate of bug 9791 ***