Bug 9791 - Managing DNS entries with MMC shows random data
Managing DNS entries with MMC shows random data
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: DCE-RPCs and pipes
unspecified
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9799 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-14 16:39 UTC by Marcel Ritter
Modified: 2015-03-15 20:59 UTC (History)
10 users (show)

See Also:


Attachments
Screenshot 1: Before pressing F5 (135.98 KB, image/jpeg)
2013-04-14 16:39 UTC, Marcel Ritter
no flags Details
Screenshot 2: After pressing F5 (137.44 KB, image/jpeg)
2013-04-14 16:39 UTC, Marcel Ritter
no flags Details
Screenshot of my DNS MMC snap-in (306.57 KB, image/png)
2013-04-24 12:03 UTC, dzorgnotti
no flags Details
Initialize dwFlags field of DNS_RPC_NODE structure (1.00 KB, patch)
2014-10-20 14:18 UTC, Samuel Cabrero
no flags Details
4.2 patch cherry-picked from master (1.17 KB, patch)
2015-03-08 20:58 UTC, Andrew Bartlett
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Ritter 2013-04-14 16:39:01 UTC
Created attachment 8770 [details]
Screenshot 1: Before pressing F5

Base system: Ubuntu 12.04.2
Samba: latest git version

Reproduce:
Manage samba's DNS entries from a Windows 7 MMC:

Go to reverse zone: A few random containers appear (last part of listed reverse IP addresses). Pressing F5 changes them to other random values (sometimes a few reloads are required to trigger this behaviour).

Two screenshots showing this are attached.

Something similar happens in the forward zone: some of the a records are also displayed as containers, however F5 does not seem to randomize this output
(this can also be seen in the screenshot - but it's not marked)
Comment 1 Marcel Ritter 2013-04-14 16:39:38 UTC
Created attachment 8771 [details]
Screenshot 2: After pressing F5
Comment 2 doofdilla 2013-04-16 14:01:32 UTC
We have the exact same problem as outlined above.

System: Ubuntu 12.04
Samba Version 4.0.3 and 4.0.5
Bind Version 9.8.1-P1 (package) and 9.8.4-P2 (self compiled)

And all combinations of the the above versions

Windows 7 DNS MMC Version: 6.1.7601.17514

Additional Note: It also happened after we migrated to the samba internal dns
Comment 3 Björn Jacke 2013-04-17 13:07:30 UTC
*** Bug 9799 has been marked as a duplicate of this bug. ***
Comment 4 doofdilla 2013-04-17 13:08:29 UTC
We have used a german Windows 7 if this might be of any interest, as i have
seen in the screenshots that the original poster was using a german version as
well.
Comment 5 doofdilla 2013-04-17 14:52:12 UTC
We just tried it with a english version of Windows 7, same behavior.

On the other hand, our ubuntu locale is set to "DE_DE.UTF-8"
Comment 6 dzorgnotti 2013-04-24 12:01:14 UTC
Hi,

I just installed a fresh samba4 (from git) on Ubunbtu 12.10 (x64).
After the initial domain-deployment I'm seeing ghost entries (or random data as the topic starter called it) in my "dns" snap-in on my windows client.
Every refresh triggers a new view.

root@samba4dc:~# samba -V
Version 4.0.5

root@samba4dc:~# locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"

root@samba4dc:~# dpkg -l ntp bind9

||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  bind9          1:9.8.1.dfsg amd64        Internet Domain Name Server
ii  ntp            1:4.2.6.p3+d amd64        Network Time Protocol daemon and 

Client OS: Win XP SP3 (German)
MMC Version: 3
I'm using the latest version of the Windows Server 2003 Administration Tools Pack (http://www.microsoft.com/en-us/download/confirmation.aspx?id=16770).
Comment 7 dzorgnotti 2013-04-24 12:03:31 UTC
Created attachment 8811 [details]
Screenshot of my DNS MMC snap-in
Comment 8 Justin Foreman 2013-05-10 14:44:42 UTC
Same behavior as others are reporting. Ghost entries change upon refresh. Using internal DNS server. Performed a migration from 3.x to 4. 

root@dc1:~# samba -V
Version 4.0.5

root@dc1:~# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 12.04.2 LTS
Release:	12.04
Codename:	precise

root@dc1:~# locale
LANG=en_US.UTF-8
LANGUAGE=en_US:
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Comment 9 dzorgnotti 2013-05-20 08:40:56 UTC
Ok, since all of us used Ubuntu 12.X and we've had our problems I tried CentOS 6 (x64).

What can I say?
Different distribution, different package versions (ntp, bind from repos) - same problem with samba 4.0.5 (build from tarball).

I used my (same old) WinXP-Client to test though.
Comment 10 Zane Zakraisek 2013-05-29 02:02:49 UTC
Yeah this doesn't help too much but I'm running Ubuntu 13.04, Samba 4.0.6, internal DNS server, and can confirm this. I have a bunch of random DNS containers in my forward lookup zone. Most of these random containers are named after my CNAME records.
Comment 11 Marcio Carlos 2013-06-28 21:59:43 UTC
I have Centos 6.3 and Samba4.0.6 and have same problem, my subfolders is gray and can´t acess for view or remove . Tks for help or fix! :)
Comment 12 Dustin C. Hatch 2013-10-27 16:20:52 UTC
Same issue here on Gentoo amd64 with Samba-4.1.0. My locale is "POSIX" (also tried en_US.UTF-8). Sometimes, entries show up as though they are glue records, instead of real entries, but refreshing the view enough times almost always makes them show up correctly.

My Samba DC was created by joining an existing Windows Server 2008 R2 domain, but the original DC has since been removed.
Comment 13 Kai Blin 2014-05-16 07:34:38 UTC
As the MMC snap-in talks to the server via the dnsserver RPC pipe, this is related to DCE/RPC. Changing component.
Comment 14 Samuel Cabrero 2014-10-20 14:18:19 UTC
Created attachment 10358 [details]
Initialize dwFlags field of DNS_RPC_NODE structure

Hi,

this patch fixes the displaying issue. The dwFlags field was not initialized so its value was random in each call.
Comment 15 Andrew Bartlett 2015-03-08 20:58:55 UTC
Created attachment 10828 [details]
4.2 patch cherry-picked from master
Comment 16 Jeremy Allison 2015-03-09 17:16:29 UTC
Re-assigning to Karolin for inclusion in 4.2.1.
Comment 17 Karolin Seeger 2015-03-09 20:58:39 UTC
Pushed to autobuild-v4-2-test.
Comment 18 Karolin Seeger 2015-03-15 20:59:22 UTC
Pushed to v4-2-test.
Closing out bug report.

Thanks!