Bug 9606 - Invocation of xsltproc in wafsamba.py uses bashism
Invocation of xsltproc in wafsamba.py uses bashism
Status: RESOLVED DUPLICATE of bug 9595
Product: Samba 4.0
Classification: Unclassified
Component: Build
4.0.1
Sparc Solaris
: P5 regression
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-26 14:36 UTC by Dagobert Michelsen
Modified: 2013-01-27 13:38 UTC (History)
1 user (show)

See Also:


Attachments
Patch (1.58 KB, patch)
2013-01-26 14:44 UTC, Dagobert Michelsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dagobert Michelsen 2013-01-26 14:36:39 UTC
The invocation of xsltproc uses an environment export of the form "export VAR=value" which does not work in pure bourne shells like the Solaris sh where this must be written as "VAR=value ; export VAR". The attached patch fixes the issue (slightly edited).
Comment 1 Dagobert Michelsen 2013-01-26 14:44:46 UTC
Created attachment 8493 [details]
Patch
Comment 2 Stefan Metzmacher 2013-01-27 13:38:26 UTC

*** This bug has been marked as a duplicate of bug 9595 ***