Bug 9564 - error too few arguments in function `solarisacl_sys_acl_get_file`
error too few arguments in function `solarisacl_sys_acl_get_file`
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
4.0.0
Sparc Solaris
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9582 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 13:47 UTC by Ralf Weinert
Modified: 2013-01-22 17:13 UTC (History)
2 users (show)

See Also:


Attachments
proposed patch (1.02 KB, patch)
2013-01-15 17:28 UTC, Björn Baumbach
no flags Details
proposed patch cherry-picked from master (1019 bytes, patch)
2013-01-16 15:00 UTC, Björn Baumbach
metze: review+
abartlet: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Weinert 2013-01-15 13:47:09 UTC
Compiling and binding samba 4.0.1 stops line 303 when compiling modules/vfs_solarisacl.c. The error message I wrote in the summary line above. the same thing happens compiling samba 4.0.0 and samba 4.0.1.
Comment 1 Björn Baumbach 2013-01-15 17:28:43 UTC
Created attachment 8433 [details]
proposed patch
Comment 2 Björn Baumbach 2013-01-15 17:29:50 UTC
This was introduced by commit 910925855fb14abe49e9f7f23f95acb61135f617 (cherry-picked from 9158974540d0e311021f04789ed75ebda466c5b3).

Can you try the patch?
Comment 3 Ralf Weinert 2013-01-16 09:05:45 UTC
Okay,

compiling succeeds now with this patch.

Thanks.
Comment 4 Björn Baumbach 2013-01-16 13:55:39 UTC
(In reply to comment #3)
> Okay,
> 
> compiling succeeds now with this patch.
> 
> Thanks.

Fine!
But please don't close (or mark as fixed) bug reports. Now it's fixed for you but not in the upstream code :-)

First we'll fix this in master. Afterwards our release manager will include the working patch for the next 4.0 release and close this bug.

Björn
Comment 5 Björn Baumbach 2013-01-16 15:00:27 UTC
Created attachment 8437 [details]
proposed patch cherry-picked from master

This issue is already fixed in master by commit 5b80f4287c8e6ae2e86cdc66e5de2b53272a77aa
Comment 6 Björn Baumbach 2013-01-16 15:02:23 UTC
(In reply to comment #5)
> This issue is already fixed in master by commit

26bae894f2ae898c51535dda14060ecf4786c6ec
Comment 7 Björn Baumbach 2013-01-17 09:19:33 UTC
Karolin, please pick for 4.0.NEXT.
Thanks
Comment 8 Karolin Seeger 2013-01-18 08:45:00 UTC
Pushed to autobuild-v4-0-test.
Comment 9 Karolin Seeger 2013-01-18 11:56:04 UTC
Pushed to v4-0-test.
Closing out bug report.

Thanks!
Comment 10 Christian Ambach 2013-01-22 17:13:17 UTC
*** Bug 9582 has been marked as a duplicate of this bug. ***