Bug 9544 - vfs_commit does not compile and does not support async write
vfs_commit does not compile and does not support async write
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: VFS Modules
4.0.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9604 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 09:01 UTC by Karolin Seeger
Modified: 2013-01-26 15:14 UTC (History)
2 users (show)

See Also:


Attachments
Patch (5.63 KB, patch)
2013-01-14 20:56 UTC, Volker Lendecke
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karolin Seeger 2013-01-07 09:01:19 UTC
[3142/3913] Compiling source3/modules/vfs_commit.c
../source3/modules/vfs_commit.c:310:9: error: unknown field ‘write’ specified in initializer
../source3/modules/vfs_commit.c:310:9: warning: initialization from incompatible pointer type [enabled by default]
../source3/modules/vfs_commit.c:310:9: warning: (near initialization for ‘vfs_commit_fns.read_fn’) [enabled by default]
../source3/modules/vfs_commit.c:311:9: error: unknown field ‘pwrite’ specified in initializer
../source3/modules/vfs_commit.c:311:9: warning: initialization from incompatible pointer type [enabled by default]
../source3/modules/vfs_commit.c:311:9: warning: (near initialization for ‘vfs_commit_fns.pread_fn’) [enabled by default]
../source3/modules/vfs_commit.c:313:9: error: unknown field ‘ftruncate’ specified in initializer
../source3/modules/vfs_commit.c:314:1: warning: initialization from incompatible pointer type [enabled by default]
../source3/modules/vfs_commit.c:314:1: warning: (near initialization for ‘vfs_commit_fns.disconnect_fn’) [enabled by default]
Waf: Leaving directory `/data/git/samba/master/bin'
Build failed:  -> task failed (err #1): 
        {task: cc vfs_commit.c -> vfs_commit_39.o}                                                                                                                             
make: *** [all] Fehler 1
Comment 1 Volker Lendecke 2013-01-14 20:56:38 UTC
Created attachment 8428 [details]
Patch

This fixes it for me. Not sure who to ask for review, Jeremy has already done two today :-)
Comment 2 Jeremy Allison 2013-01-14 21:43:09 UTC
I'm on a roll today. Just assign to me :-).

Jeremy.
Comment 3 Volker Lendecke 2013-01-15 09:05:56 UTC
Comment on attachment 8428 [details]
Patch

Jeremy, if you're happy with it, please push to master.

Thanks,

Volker
Comment 4 Volker Lendecke 2013-01-15 09:07:40 UTC
(In reply to comment #3)
> Comment on attachment 8428 [details]
> Patch
> 
> Jeremy, if you're happy with it, please push to master.
> 
> Thanks,
> 
> Volker

Okay, gone in already...

Volker
Comment 5 Jeremy Allison 2013-01-15 16:45:05 UTC
Comment on attachment 8428 [details]
Patch

LGTM.
Comment 6 Jeremy Allison 2013-01-15 16:45:36 UTC
Re-assigning to Karolin for inclusion in 4.0.next.

Jeremy.
Comment 7 Karolin Seeger 2013-01-16 09:06:38 UTC
Pushed to autobuild-v4-0-test.
Comment 8 Karolin Seeger 2013-01-16 10:10:55 UTC
Can confirm that vfs_commit compiles on my system after applying the patches.
Comment 9 Karolin Seeger 2013-01-17 08:00:58 UTC
Pushed to v4-0-test.
Closing out bug report.

Thanks!
Comment 10 Volker Lendecke 2013-01-26 15:14:40 UTC
*** Bug 9604 has been marked as a duplicate of this bug. ***