Bug 9541 - Add support for posix_openpt
Add support for posix_openpt
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: DCE-RPCs and pipes
3.6.10
All All
: P5 enhancement
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 9510 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 00:11 UTC by Ian McWilliam
Modified: 2013-01-22 10:56 UTC (History)
1 user (show)

See Also:


Attachments
Add support for posix_openpt (1.21 KB, text/plain)
2013-01-07 00:11 UTC, Ian McWilliam
no flags Details
Patch for 4.0 and master (3.18 KB, patch)
2013-01-12 18:34 UTC, Volker Lendecke
jra: review+
Details
Patch for v3-6-test (3.61 KB, patch)
2013-01-16 16:12 UTC, Volker Lendecke
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian McWilliam 2013-01-07 00:11:18 UTC
Created attachment 8385 [details]
Add support for posix_openpt

The attached patch adds support for posix_openpt() for opening a pseudo-terminal device. 
On OpenBSD it is better than

/* Try to open /dev/ptmx. If that fails, fall through to old method. */

The patch is currently incorporated into the OpenBSD port of net/samba (3.6.10) and it would be great if the samba folk could pull it into the samba tree.

Thanx muchly.
Comment 1 Volker Lendecke 2013-01-12 18:34:06 UTC
Created attachment 8415 [details]
Patch for 4.0 and master

This was acked in https://lists.samba.org/archive/samba-technical/2013-January/089880.html on the list. Jeremy, please push to master if you agree.

Thanks
Comment 2 Volker Lendecke 2013-01-14 09:40:42 UTC
*** Bug 9510 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Allison 2013-01-14 17:01:49 UTC
Comment on attachment 8415 [details]
Patch for 4.0 and master

Pushed to master !
Comment 4 Jeremy Allison 2013-01-14 17:02:25 UTC
Re-assigned to Karolin for inclusion in 4.0.next.

Jeremy.
Comment 5 Volker Lendecke 2013-01-16 16:12:21 UTC
Created attachment 8439 [details]
Patch for v3-6-test

Also required for 3.6 obviously
Comment 6 Jeremy Allison 2013-01-16 19:09:29 UTC
Comment on attachment 8439 [details]
Patch for v3-6-test

LGTM for 3.6.next.
Jeremy.
Comment 7 Jeremy Allison 2013-01-16 19:12:50 UTC
Re-assigning to Karolin for inclusion in 3.6.next.
Jeremy.
Comment 8 Brad Smith 2013-01-19 01:06:05 UTC
Karolin, can you please get this in before 3.6.11 goes out?
Comment 9 Karolin Seeger 2013-01-21 08:11:19 UTC
(In reply to comment #8)
> Karolin, can you please get this in before 3.6.11 goes out?

I am sorry, but it will be in 3.6.12.
The release branch is usually closed one week before the release date.
Comment 10 Karolin Seeger 2013-01-21 10:15:59 UTC
Pushed to autobuild-v4-0-test and v3-6-test.
Comment 11 Karolin Seeger 2013-01-22 10:56:48 UTC
Pushed to v4-0-test.
Closing out bug report.

Thanks!