Bug 9325 - smdb, PANIC, internal error, no connection to DC?
smdb, PANIC, internal error, no connection to DC?
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.8
x64 FreeBSD
: P5 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on: 9330
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 12:42 UTC by Michael Letzgus
Modified: 2012-12-04 11:01 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Letzgus 2012-10-23 12:42:27 UTC
Hi,

after updating from 3.6.7 to 3.6.8 smbd has problems:

Oct 23 12:19:35 pc1 smbd[38310]: [2012/10/23 12:19:35.877698, 0] rpc_client/cli_pipe_schannel.c:184(cli_rpc_pipe_open_schannel)
Oct 23 12:19:35 pc1 smbd[38310]: cli_rpc_pipe_open_schannel: failed to get schannel session key from server DC1.AD.UNI-BIELEFELD.DE for domain AD.
Oct 23 12:19:35 pc1 smbd[38310]: [2012/10/23 12:19:35.877823, 0] auth/auth_domain.c:193(connect_to_domain_password_server)
Oct 23 12:19:35 pc1 smbd[38310]: connect_to_domain_password_server: unable to open the domain client session to machine DC1.AD.UNI-BIELEFELD.DE. Error was : NT_STATUS_ACCESS_DENIED.
Oct 23 12:19:35 pc1 smbd[38310]: [2012/10/23 12:19:35.886597, 0] rpc_client/cli_pipe_schannel.c:184(cli_rpc_pipe_open_schannel)

[...]

Oct 23 13:35:44 pc1 smbd[46818]: INTERNAL ERROR: Signal 11 in pid 46818 (3.6.8)
Oct 23 13:35:44 pc1 smbd[46818]: Please read the Trouble-Shooting section of the Samba3-HOWTO
Oct 23 13:35:44 pc1 smbd[46818]: [2012/10/23 13:35:44.673042, 0] lib/fault.c:54(fault_report)
Oct 23 13:35:44 pc1 smbd[46818]:
Oct 23 13:35:44 pc1 smbd[46818]: From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
Oct 23 13:35:44 pc1 smbd[46818]: [2012/10/23 13:35:44.673062, 0] lib/fault.c:55(fault_report)
Oct 23 13:35:44 pc1 smbd[46818]: ===============================================================
Oct 23 13:35:44 pc1 smbd[46818]: [2012/10/23 13:35:44.673077, 0] lib/util.c:1117(smb_panic)
Oct 23 13:35:44 pc1 smbd[46818]: PANIC (pid 46818): internal error


Since reverting back to 3.6.7 everything is fine.
Comment 1 Michael Letzgus 2012-10-25 15:18:49 UTC
I think it's caused by bug 9330 (https://bugzilla.samba.org/show_bug.cgi?id=9330).
Comment 2 Karolin Seeger 2012-12-04 11:01:28 UTC
Should be fixed.
Closing out bug report.

Please feel free to re-open if it's still an issue.

Thanks!