Bug 9324 - winbindd cannot connect DCs, lost AD memebership?
winbindd cannot connect DCs, lost AD memebership?
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Winbind
3.6.8
x64 FreeBSD
: P5 critical
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on: 9330
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 12:39 UTC by Michael Letzgus
Modified: 2012-12-04 11:00 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Letzgus 2012-10-23 12:39:55 UTC
Hi,

after upgrading from Samba 3.6.7 to 3.6.8 "something" was wrong with the AD membership:

* net ads testjoin => OK
* wbinfo -P => failed
* wbinfo -t => failed


winbindd logs a lot of these messages:

winbindd/winbindd_cm.c:1015(cm_prepare_connection)
failed tcon_X with NT_STATUS_ACCESS_DENIED


Oct 23 13:22:00 pc1 winbindd[42932]: [2012/10/23 13:22:00.194727, 0] winbindd/winbindd_util.c:635(init_domain_list)
Oct 23 13:22:00 pc1 winbindd[42932]: Could not fetch our SID - did we join?
Oct 23 13:22:00 pc1 winbindd[42932]: [2012/10/23 13:22:00.194825, 0] winbindd/winbindd.c:1108(winbindd_register_handlers)
Oct 23 13:22:00 pc1 winbindd[42932]: unable to initialize domain list
Comment 1 Michael Letzgus 2012-10-25 15:17:44 UTC
I think it's caused by bug 9330 (https://bugzilla.samba.org/show_bug.cgi?id=9330).
Comment 2 Karolin Seeger 2012-12-04 11:00:59 UTC
Should be fixed.
Closing out bug report.

Please feel free to re-open if it's still an issue.

Thanks!