Bug 9323 - net ads join segfaults
net ads join segfaults
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Client Tools
3.6.8
x64 FreeBSD
: P5 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on: 9330
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 12:36 UTC by Michael Letzgus
Modified: 2012-12-04 11:00 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Letzgus 2012-10-23 12:36:44 UTC
Hi,

with Samba 3.6.8 "net" behaves wrong:

"net ad join" now asks for the password of user "(null)" instead of "root".

"net ad join -U domainadmin" crashes after entering the password
Comment 1 Michael Letzgus 2012-10-25 15:18:35 UTC
I think it's caused by bug 9330 (https://bugzilla.samba.org/show_bug.cgi?id=9330).

The ("null") is caused by a missing LOGNAME=root variable after a "su -l root"
Comment 2 Karolin Seeger 2012-12-04 11:00:29 UTC
Should be fixed.
Closing out bug report.

Please feel free to re-open if it's still an issue.

Thanks!