Bug 927 - the <xi:include> tags in the smb.conf page (us1 and us2.samba.org) don't load the included sections
the <xi:include> tags in the smb.conf page (us1 and us2.samba.org) don't load...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.1
Other other
: P3 normal
: none
Assigned To: Jelmer Vernooij
http://us2.samba.org/samba/docs/man/s...
:
: 928 929 930 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 04:40 UTC by Ignacio Coupeau
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignacio Coupeau 2003-12-29 04:40:33 UTC
COMPLETE LIST OF GLOBAL PARAMETERS

Here is a list of all global parameters. See the section of each parameter for
details. Note that some are synonyms.
<xi:include></xi:include>
COMPLETE LIST OF SERVICE PARAMETERS

Here is a list of all service parameters. See the section on each parameter for
details. Note that some are synonyms.
<xi:include></xi:include>
EXPLANATION OF EACH PARAMETER
<xi:include></xi:include>
WARNINGS
Comment 1 Gerald (Jerry) Carter 2003-12-29 09:19:45 UTC
Thanks.  We're working on it.
Comment 2 Alexander Bokovoy 2003-12-29 10:23:21 UTC
There are bugs in XInclude/2003 support in libxml2 which lead to various errors
with XInclude processing in samba-docs.

Basically:
 -- old libxml2 (< 2.6.3) does not know about XInclude/2003 and processes only
XInclude/2001.
 -- new implementation of XInclude processing in libxml2 2.6.3 and CVS is broken
(see various bug reports in GNOME's bugzilla: 129932, 129965, 129967, 129969)
and even after fixing all of them there are reproduceable segfaults.

XInclude/2001 is still supported in libxml2 2.6.3 and CVS while emitting
warnings about 'deprecated' standard, which is non-issue.
Comment 3 Jelmer Vernooij 2004-01-02 06:09:46 UTC
Fixed in CVS. 
Comment 4 Gerald (Jerry) Carter 2004-01-07 09:53:18 UTC
*** Bug 928 has been marked as a duplicate of this bug. ***
Comment 5 Gerald (Jerry) Carter 2004-01-07 09:54:05 UTC
*** Bug 929 has been marked as a duplicate of this bug. ***
Comment 6 Gerald (Jerry) Carter 2004-01-07 09:56:12 UTC
*** Bug 930 has been marked as a duplicate of this bug. ***
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:24:30 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.