Bug 909 - Failed to set uid privileges to (-1,65535) now set to (0,0)
Failed to set uid privileges to (-1,65535) now set to (0,0)
Status: RESOLVED DUPLICATE of bug 1176
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.1
All Linux
: P2 critical
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-22 05:06 UTC by Alexander Newald
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Newald 2003-12-22 05:06:54 UTC
Hello,

I've installed the latest samba (3.0.1) on my local test mashine and get the
fullowing error while opening a file when I already have the status of:

Samba version 3.0.1
PID     Username      Group         Machine
-------------------------------------------------------------------
21236   alex          users         alex         (192.168.0.111)

Service      pid     machine       Connected at
-------------------------------------------------------
tmp          21236   alex          Fri Dec 19 17:38:25 2003
alex         21236   alex          Fri Dec 19 17:37:40 2003
Locked files:
Pid    DenyMode   Access      R/W        Oplock           Name
--------------------------------------------------------------
21236  DENY_NONE  0x20089     RDONLY     NONE
/home/alex/test.mp3

The error is:

[2003/12/19 17:37:40, 0] lib/util_sec.c:assert_uid(95)
  Failed to set uid privileges to (-1,65535) now set to (0,0)
[2003/12/19 17:37:40, 0] lib/util.c:smb_panic(1400)
  PANIC: failed to set uid

[2003/12/19 17:37:40, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 17 stack frames:
   #0 /opt/samba-3.0.1/sbin/smbd(smb_panic+0x1ab) [0x81a5751]
   #1 /opt/samba-3.0.1/sbin/smbd [0x81a9fb8]
   #2 /opt/samba-3.0.1/sbin/smbd(set_effective_uid+0x30) [0x81aa182]
   #3 /opt/samba-3.0.1/sbin/smbd [0x80b49b2]
   #4 /opt/samba-3.0.1/sbin/smbd [0x80b4a70]
   #5 /opt/samba-3.0.1/sbin/smbd(set_sec_ctx+0x14d) [0x80b5225]
   #6 /opt/samba-3.0.1/sbin/smbd(change_to_user+0x361) [0x80ade1d]
   #7 /opt/samba-3.0.1/sbin/smbd [0x80c3914]
   #8 /opt/samba-3.0.1/sbin/smbd(make_connection+0x6b3) [0x80c46af]
   #9 /opt/samba-3.0.1/sbin/smbd(reply_tcon_and_X+0x2af) [0x8095d3d]
   #10 /opt/samba-3.0.1/sbin/smbd [0x80c0c05]
   #11 /opt/samba-3.0.1/sbin/smbd [0x80c0cb6]
   #12 /opt/samba-3.0.1/sbin/smbd(process_smb+0x1ed) [0x80c1005]
   #13 /opt/samba-3.0.1/sbin/smbd(smbd_process+0x16c) [0x80c1b4c]
   #14 /opt/samba-3.0.1/sbin/smbd(main+0x7b4) [0x81ff828]
   #15 /lib/libc.so.6(__libc_start_main+0xa2) [0x40d28552]
   #16 /opt/samba-3.0.1/sbin/smbd(chroot+0x39) [0x8071911]
[2003/12/19 17:37:40, 1] smbd/service.c:make_connection_snum(705)
  alex (192.168.0.111) connect to service alex initially as user alex
(uid=1001, gid=100) (pid 21236)

Playing of the test.mp3 file stops, the new file (Test black jpg image) I
try to open is mostly ok but at 1 out of 10 the file is trunked.

Samba is running as

root     22350  0.0  0.4  5240 2004 ?        S    17:09   0:00
/opt/samba-3.0.1/sbin/smbd -s /etc/smb.conf
alex     21236  0.4  0.7  5916 3172 ?        S    17:37   0:02  \_
/opt/samba-3.0.1/sbin/smbd -s /etc/smb.conf
root      8591  0.0  0.4  3668 1828 ?        S    17:09   0:00
/opt/samba-3.0.1/sbin/nmbd -s /etc/smb.conf

smb.conf is the default smb.conf except I changed "hosts allow" to hosts
allow = 192.168.0. 127.

I build samba from source with:

./configure --prefix=/opt/samba-3.0.1            \
            --sysconfdir=/etc/samba              \
            --localstatedir=/var/spool/samba     \
            --with-smbmount && make && make install

Compiled with gcc 3.2

Alexander Newald
Comment 1 Gerald (Jerry) Carter 2004-03-22 08:14:15 UTC

*** This bug has been marked as a duplicate of 1176 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:31:23 UTC
database cleanup