Bug 1176 - abort("Failed to set gid privileges" ) on 2.6.1 kernel
abort("Failed to set gid privileges" ) on 2.6.1 kernel
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
http://www.hasw.net/linux/samba
:
: 909 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 05:04 UTC by Sebastian Witt
Modified: 2008-04-21 22:46 UTC (History)
1 user (show)

See Also:


Attachments
Samba test log with 2.6.4 kernel (79.47 KB, text/plain)
2004-03-17 13:16 UTC, Sebastian Witt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Witt 2004-03-11 05:04:13 UTC
samba-3.0.2a compiled with gcc 3.2.2 on Linux 2.6.1 (libc-2.3.1).
Client: W2K SP4

When opening a new connection (new explorer windows) and displaying or searching
for files on a share, the other connections (file copying,etc.) are terminated
and smbd panics:

hasw (192.168.0.10) connect to service hdb initially as user hasw (uid=1002,
gid=100) (pid 29629)
[2004/03/11 00:46:32, 0] lib/util_sec.c:assert_gid(113)
  Failed to set gid privileges to (-1,65535) now set to (0,0) uid=(0,0)
[2004/03/11 00:46:32, 0] lib/util.c:smb_panic(1400)
  PANIC: failed to set gid
  
[2004/03/11 00:46:32, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 25 stack frames:
   #0 /usr/sbin/smbd(smb_panic+0x1ab) [0x81ad32c]
   #1 /usr/sbin/smbd [0x81b1c5f]
   #2 /usr/sbin/smbd(set_effective_gid+0x34) [0x81b1d6f]
   #3 /usr/sbin/smbd [0x81fecfb]
   #4 /usr/sbin/smbd(sys_getgrouplist+0x150) [0x81fef3d]
   #5 /usr/sbin/smbd [0x81e5bb7]
   #6 /usr/sbin/smbd [0x81e5f73]
   #7 /usr/sbin/smbd(make_server_info_sam+0x11c) [0x81e6237]
   #8 /usr/sbin/smbd(make_server_info_guest+0xa3) [0x81e644e]
   #9 /usr/sbin/smbd [0x81e43bc]
   #10 /usr/sbin/smbd [0x81dfbec]
   #11 /usr/sbin/smbd [0x81e7e26]
   #12 /usr/sbin/smbd [0x80f2af5]
   #13 /usr/sbin/smbd(ntlmssp_update+0x1ea) [0x80f1e89]
   #14 /usr/sbin/smbd(auth_ntlmssp_update+0x3d) [0x81e8161]
   #15 /usr/sbin/smbd [0x80a30f0]
   #16 /usr/sbin/smbd [0x80a3421]
   #17 /usr/sbin/smbd(reply_sesssetup_and_X+0x19b) [0x80a36bc]
   #18 /usr/sbin/smbd [0x80c23f3]
   #19 /usr/sbin/smbd [0x80c24a3]
   #20 /usr/sbin/smbd(process_smb+0x1ed) [0x80c27ee]
   #21 /usr/sbin/smbd(smbd_process+0x16c) [0x80c3332]
   #22 /usr/sbin/smbd(main+0x7b4) [0x8206ab9]
   #23 /lib/libc.so.6(__libc_start_main+0xa4) [0x40166f14]
   #24 /usr/sbin/smbd(yp_get_default_domain+0x5d) [0x8071ec1]
[2004/03/11 00:46:32, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/03/11 00:46:32, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 6 in pid 29629 (3.0.2a)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/03/11 00:46:32, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/03/11 00:46:32, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/03/11 00:46:32, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 30 stack frames:
   #0 /usr/sbin/smbd(smb_panic+0x1ab) [0x81ad32c]
   #1 /usr/sbin/smbd [0x819bfe1]
   #2 /usr/sbin/smbd [0x819c056]
   #3 /lib/libc.so.6 [0x4017aea8]
   #4 /lib/libc.so.6(abort+0x1ac) [0x4017c4dc]
   #5 /usr/sbin/smbd(readdirname+0) [0x81ad3e7]
   #6 /usr/sbin/smbd [0x81b1c5f]
   #7 /usr/sbin/smbd(set_effective_gid+0x34) [0x81b1d6f]
   #8 /usr/sbin/smbd [0x81fecfb]
   #9 /usr/sbin/smbd(sys_getgrouplist+0x150) [0x81fef3d]
   #10 /usr/sbin/smbd [0x81e5bb7]
   #11 /usr/sbin/smbd [0x81e5f73]
   #12 /usr/sbin/smbd(make_server_info_sam+0x11c) [0x81e6237]
   #13 /usr/sbin/smbd(make_server_info_guest+0xa3) [0x81e644e]
   #14 /usr/sbin/smbd [0x81e43bc]
   #15 /usr/sbin/smbd [0x81dfbec]
   #16 /usr/sbin/smbd [0x81e7e26]
   #17 /usr/sbin/smbd [0x80f2af5]
   #18 /usr/sbin/smbd(ntlmssp_update+0x1ea) [0x80f1e89]
   #19 /usr/sbin/smbd(auth_ntlmssp_update+0x3d) [0x81e8161]
   #20 /usr/sbin/smbd [0x80a30f0]
   #21 /usr/sbin/smbd [0x80a3421]
   #22 /usr/sbin/smbd(reply_sesssetup_and_X+0x19b) [0x80a36bc]
   #23 /usr/sbin/smbd [0x80c23f3]
   #24 /usr/sbin/smbd [0x80c24a3]
   #25 /usr/sbin/smbd(process_smb+0x1ed) [0x80c27ee]
   #26 /usr/sbin/smbd(smbd_process+0x16c) [0x80c3332]
   #27 /usr/sbin/smbd(main+0x7b4) [0x8206ab9]
   #28 /lib/libc.so.6(__libc_start_main+0xa4) [0x40166f14]
   #29 /usr/sbin/smbd(yp_get_default_domain+0x5d) [0x8071ec1]
[2004/03/11 00:46:32, 0] smbd/oplock_linux.c:linux_init_kernel_oplocks(289)
  Failed to setup RT_SIGNAL_LEASE handler
[2004/03/11 00:46:32, 1] smbd/service.c:make_connection_snum(705)
  hasw (192.168.0.10) connect to service hdb initially as user hasw (uid=1002,
gid=100) (pid 29631)
[2004/03/11 00:48:58, 1] smbd/service.c:make_connection_snum(705)
  hasw (192.168.0.10) connect to service hda initially as user hasw (uid=1002,
gid=100) (pid 29631)
[2004/03/11 00:53:55, 1] smbd/service.c:make_connection_snum(705)
  hasw (192.168.0.10) connect to service raid initially as user hasw (uid=1002,
gid=100) (pid 29631)
[2004/03/11 00:54:18, 0] lib/util_sec.c:assert_gid(113)
  Failed to set gid privileges to (-1,65535) now set to (0,0) uid=(0,0)
[2004/03/11 00:54:18, 0] lib/util.c:smb_panic(1400)
  PANIC: failed to set gid
.....

assert_gid(-1, 65535) is called from line 235 in source/lib/util_sec.c

The full log is available at http://www.hasw.net/linux/samba/bug.log
reproduced with a higher log level on 
http://www.hasw.net/linux/samba/bug2.log.bz2

GID 65535 is "nogroup".
smb.conf: http://www.hasw.net/linux/samba/smb.conf
Comment 1 Gerald (Jerry) Carter 2004-03-17 10:15:56 UTC
any chance you could try on a later 2.6 kernel ?
Sounds like a kernel bug to me.  Thanks.
Comment 2 Sebastian Witt 2004-03-17 13:16:13 UTC
Created attachment 445 [details]
Samba test log with 2.6.4 kernel
Comment 3 Sebastian Witt 2004-03-17 13:22:11 UTC
Now tried with:
Linux server3 2.6.4 #1 SMP Wed Mar 17 21:52:12 CET 2004 i686 unknown unknown
GNU/Linux

the same message:
  Failed to set gid privileges to (-1,65535) now set to (0,0) uid=(0,0)
[2004/03/17 22:09:11, 0] lib/util.c:smb_panic(1400)
  PANIC: failed to set gid

I've attached the log file.
Comment 4 Gerald (Jerry) Carter 2004-03-22 08:14:15 UTC
*** Bug 909 has been marked as a duplicate of this bug. ***
Comment 5 Sebastian Witt 2004-05-06 12:34:06 UTC
Seems to be fixed in 3.0.3 (using kernel 2.6.5).
Comment 6 Gerald (Jerry) Carter 2004-05-06 14:00:14 UTC
Excellenet news.  Thanks.
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:24:45 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 8 Gerald (Jerry) Carter 2005-11-14 09:28:40 UTC
database cleanup
Comment 9 pinyo 2008-04-21 22:46:37 UTC
(In reply to comment #8)
> database cleanup

Hi,

  I use kernel version and samba version as below but still got error messages then server reboot. Any suggestion.

# uname -r
2.6.9-42.ELsmp
# rpm -q samba
samba-3.0.10-1.4E.9