Bug 908 - smbcontrol configfile option dosen't work
smbcontrol configfile option dosen't work
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Upgrade
3.0.1
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
: 795 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-22 04:34 UTC by Oded Porat
Modified: 2005-11-14 09:28 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oded Porat 2003-12-22 04:34:36 UTC
When issuing smbcontrol command with configfile option you get the following 
error:

$ smbcontrol -t 1 -s /etc/samba/smb.conf nmbd ping
params.c:OpenConfFile() - Unable to open configuration file "":
        Argument list too long

Fix: 
"diff -u smbcontrol.c{.orig,}"
--- smbcontrol.c.orig   2003-12-22 14:28:43.000000000 +0200
+++ smbcontrol.c        2003-12-22 14:29:19.000000000 +0200
@@ -717,7 +717,7 @@
                        argc -= 2;
                        break;
                case 's':       /* --configfile */
-                       pstrcpy(dyn_CONFIGFILE, optarg);
+                       pstrcpy(dyn_CONFIGFILE, poptGetOptArg(pc));
                        argc -= 2;
                        break;
                default:
Comment 1 Gerald (Jerry) Carter 2003-12-22 13:41:34 UTC
*** Bug 795 has been marked as a duplicate of this bug. ***
Comment 2 Jelmer Vernooij 2004-01-06 12:04:14 UTC
Fixed in CVS.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:24:57 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:28:48 UTC
database cleanup